summaryrefslogtreecommitdiff
path: root/sys-cluster/legion/legion-23.03.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/legion/legion-23.03.0.ebuild')
-rw-r--r--sys-cluster/legion/legion-23.03.0.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-cluster/legion/legion-23.03.0.ebuild b/sys-cluster/legion/legion-23.03.0.ebuild
index 95cdbf4b0a3c..55259ad9c9a6 100644
--- a/sys-cluster/legion/legion-23.03.0.ebuild
+++ b/sys-cluster/legion/legion-23.03.0.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="A data-centric parallel programming system"
HOMEPAGE="https://legion.stanford.edu/"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+ EGIT_REPO_URI="https://github.com/StanfordLegion/legion.git"
else
- SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ SRC_URI="https://github.com/StanfordLegion/legion/archive/${P}.tar.gz"
S="${WORKDIR}"/${PN}-${P}
KEYWORDS="~amd64"
@@ -34,6 +34,11 @@ PATCHES=(
)
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/863731
+ # Fixed upstream / in live ebuild.
+ filter-lto
+
local mycmakeargs=(
-DLegion_USE_HWLOC=$(usex hwloc)
-DLegion_USE_GASNet=$(usex gasnet)