summaryrefslogtreecommitdiff
path: root/sys-cluster/glusterfs/glusterfs-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/glusterfs/glusterfs-9999.ebuild')
-rw-r--r--sys-cluster/glusterfs/glusterfs-9999.ebuild64
1 files changed, 24 insertions, 40 deletions
diff --git a/sys-cluster/glusterfs/glusterfs-9999.ebuild b/sys-cluster/glusterfs/glusterfs-9999.ebuild
index 544b9e693be5..718ab4740bc1 100644
--- a/sys-cluster/glusterfs/glusterfs-9999.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-9999.ebuild
@@ -3,15 +3,15 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6..9} )
-inherit autotools elisp-common python-single-r1 systemd user
+inherit autotools elisp-common python-single-r1 systemd
if [[ ${PV#9999} != ${PV} ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/gluster/glusterfs.git"
else
- SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(ver_cut '1-2')/${PV}/${P}.tar.gz"
+ SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(ver_cut 1)/${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
@@ -20,40 +20,39 @@ HOMEPAGE="https://www.gluster.org/"
LICENSE="|| ( GPL-2 LGPL-3+ )"
SLOT="0"
-IUSE="bd-xlator crypt-xlator debug emacs +fuse +georeplication glupy infiniband ipv6 libressl +libtirpc qemu-block rsyslog static-libs +syslog systemtap test +tiering vim-syntax +xml"
+IUSE="debug emacs +fuse +georeplication infiniband ipv6 libressl +libtirpc rsyslog static-libs +syslog test vim-syntax +xml"
REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )
- glupy? ( ${PYTHON_REQUIRED_USE} )
ipv6? ( libtirpc )"
# the tests must be run as root
RESTRICT="test"
# sys-apps/util-linux is required for libuuid
-RDEPEND="bd-xlator? ( sys-fs/lvm2 )
- !elibc_glibc? ( sys-libs/argp-standalone )
+RDEPEND="
+ acct-group/gluster
+ acct-user/gluster
+ dev-libs/libaio
+ dev-libs/userspace-rcu:=
+ net-libs/rpcsvc-proto
+ sys-apps/util-linux
+ sys-libs/readline:=
emacs? ( >=app-editors/emacs-23.1:* )
fuse? ( >=sys-fs/fuse-2.7.0:0 )
georeplication? ( ${PYTHON_DEPS} )
infiniband? ( sys-fabric/libibverbs:* sys-fabric/librdmacm:* )
+ xml? ( dev-libs/libxml2 )
+ !elibc_glibc? ( sys-libs/argp-standalone )
libtirpc? ( net-libs/libtirpc:= )
!libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
- qemu-block? ( dev-libs/glib:2 )
- systemtap? ( dev-util/systemtap )
- tiering? ( dev-db/sqlite:3 )
- xml? ( dev-libs/libxml2 )
- sys-libs/readline:=
- dev-libs/libaio
!libressl? ( dev-libs/openssl:=[-bindist] )
libressl? ( dev-libs/libressl:= )
- dev-libs/userspace-rcu:=
- net-libs/rpcsvc-proto
- sys-apps/util-linux"
-DEPEND="${RDEPEND}
- virtual/acl
- virtual/pkgconfig
+"
+DEPEND="
+ ${RDEPEND}
sys-devel/bison
sys-devel/flex
+ virtual/acl
test? ( >=dev-util/cmocka-1.0.1
app-benchmarks/dbench
dev-vcs/git
@@ -61,15 +60,14 @@ DEPEND="${RDEPEND}
virtual/perl-Test-Harness
dev-libs/yajl
sys-fs/xfsprogs
- sys-apps/attr )"
+ sys-apps/attr )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
SITEFILE="50${PN}-mode-gentoo.el"
-PATCHES=(
- "${FILESDIR}/${PN}-3.12.2-poisoned-sysmacros.patch"
- "${FILESDIR}/${PN}-4.1.0-silent_rules.patch"
-)
-
DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
# Maintainer notes:
@@ -78,13 +76,8 @@ DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
# glibc or if argp-standalone is installed.
pkg_setup() {
- python_setup "python2*"
+ python_setup "python3*"
python-single-r1_pkg_setup
-
- # Needed for statedumps
- # https://github.com/gluster/glusterfs/commit/0e50c4b3ea734456c14e2d7a578463999bd332c3
- enewgroup gluster
- enewuser gluster -1 -1 "${EPREFIX}"/var/run/gluster gluster
}
src_prepare() {
@@ -104,18 +97,12 @@ src_configure() {
econf \
--disable-fusermount \
$(use_enable debug) \
- $(use_enable bd-xlator) \
- $(use_enable crypt-xlator) \
$(use_enable fuse fuse-client) \
$(use_enable georeplication) \
- $(use_enable glupy) \
$(use_enable infiniband ibverbs) \
- $(use_enable qemu-block) \
$(use_enable static-libs static) \
$(use_enable syslog) \
- $(use_enable systemtap) \
$(use_enable test cmocka) \
- $(use_enable tiering) \
$(use_enable xml xml-output) \
$(use libtirpc || echo --without-libtirpc) \
$(use ipv6 && echo --with-ipv6-default) \
@@ -184,9 +171,6 @@ src_install() {
if ! use static-libs; then
find "${D}" -type f -name '*.la' -delete || die
fi
-
- # fix all shebang for python2 #560750
- python_fix_shebang "${ED}"
}
src_test() {