summaryrefslogtreecommitdiff
path: root/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild')
-rw-r--r--sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild b/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild
index c6fc8ce35bc6..79808b9e3ff6 100644
--- a/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-8.3-r1.ebuild
@@ -98,7 +98,7 @@ src_configure() {
$(use_enable xml xml-output) \
$(use libtirpc || echo --without-libtirpc) \
$(use ipv6 && echo --with-ipv6-default) \
- --with-tmpfilesdir="${EPREFIX}"/etc/tmpfiles.d \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
--localstatedir="${EPREFIX}"/var
}
@@ -107,6 +107,10 @@ src_compile() {
use emacs && elisp-compile extras/glusterfs-mode.el
}
+src_test() {
+ ./run-tests.sh || die
+}
+
src_install() {
default
@@ -158,11 +162,9 @@ src_install() {
python_optimize "${ED}"
}
-src_test() {
- ./run-tests.sh || die
-}
-
pkg_postinst() {
+ tmpfiles_process gluster.conf
+
elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
elog " /etc/init.d/glusterd start"