summaryrefslogtreecommitdiff
path: root/sys-cluster/corosync/corosync-2.4.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/corosync/corosync-2.4.5.ebuild')
-rw-r--r--sys-cluster/corosync/corosync-2.4.5.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/sys-cluster/corosync/corosync-2.4.5.ebuild b/sys-cluster/corosync/corosync-2.4.5.ebuild
deleted file mode 100644
index 53837dc49ef1..000000000000
--- a/sys-cluster/corosync/corosync-2.4.5.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="OSI Certified implementation of a complete cluster engine"
-HOMEPAGE="http://www.corosync.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2 public-domain"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="doc infiniband static-libs systemd xml"
-
-# TODO: support those new configure flags
-# --enable-augeas : Install the augeas lens for corosync.conf
-# --enable-snmp : SNMP protocol support
-# --enable-watchdog : Watchdog support
-RDEPEND="!sys-cluster/heartbeat
- infiniband? (
- sys-fabric/libibverbs:*
- sys-fabric/librdmacm:*
- )
- dev-libs/nss
- >=sys-cluster/libqb-0.14.4"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( sys-apps/groff )"
-
-PATCHES=( "${FILESDIR}/${PN}-2.3.4-docs.patch" )
-
-DOCS=( README.recovery SECURITY AUTHORS )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- default
- # appends lib to localstatedir automatically
- # FIXME: install just shared libs --disable-static does not work
- econf_opts=(
- --localstatedir=/var \
- $(use_enable infiniband rdma) \
- $(use_enable systemd) \
- $(use_enable xml xmlconf)
- )
- use doc && econf_opts+=( --enable-doc )
- econf "${econf_opts[@]}"
-}
-
-src_install() {
- default
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
-
- if use systemd; then
- rm "${D}"/lib/systemd/system/corosync-notifyd.service || die
- else
- rm "${D}"/etc/init.d/corosync-notifyd || die
- fi
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/${PN}.logrotate ${PN}
-
- keepdir /var/lib/corosync
- use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.{,l}a || die
-
-}