summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch')
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch b/sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch
new file mode 100644
index 000000000000..ec7a4fb079b3
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch
@@ -0,0 +1,11 @@
+--- ceph-14.2.0.orig/src/common/CMakeLists.txt 2019-03-18 04:08:29.000000000 -0600
++++ ceph-14.2.0/src/common/CMakeLists.txt 2019-03-21 18:42:32.903182824 -0600
+@@ -165,7 +165,7 @@
+ crc32c_aarch64.c)
+ endif(HAVE_INTEL)
+
+-add_library(crc32 ${crc32_srcs})
++add_library(crc32 STATIC ${crc32_srcs})
+ if(HAVE_ARMV8_CRC)
+ set_target_properties(crc32 PROPERTIES
+ COMPILE_FLAGS "${CMAKE_C_FLAGS} ${ARMV8_CRC_COMPILE_FLAGS}")