summaryrefslogtreecommitdiff
path: root/sys-boot/systemd-boot/files/235-libshared-static.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/systemd-boot/files/235-libshared-static.patch')
-rw-r--r--sys-boot/systemd-boot/files/235-libshared-static.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-boot/systemd-boot/files/235-libshared-static.patch b/sys-boot/systemd-boot/files/235-libshared-static.patch
new file mode 100644
index 000000000000..2a0bf678539b
--- /dev/null
+++ b/sys-boot/systemd-boot/files/235-libshared-static.patch
@@ -0,0 +1,24 @@
+--- a/meson.build
++++ b/meson.build
+@@ -1505,9 +1505,8 @@ if conf.get('ENABLE_EFI') == 1 and conf.get('HAVE_BLKID') == 1
+ exe = executable('bootctl',
+ 'src/boot/bootctl.c',
+ include_directories : includes,
+- link_with : [libshared],
++ link_with : [libshared_static],
+ dependencies : [libblkid],
+- install_rpath : rootlibexecdir,
+ install : true)
+ public_programs += [exe]
+ endif
+diff --git a/src/shared/meson.build b/src/shared/meson.build
+index 883821352..b560e65c9 100644
+--- a/src/shared/meson.build
++++ b/src/shared/meson.build
+@@ -157,5 +157,6 @@ libshared_static = static_library(
+ libshared_name,
+ shared_sources,
+ basic_sources,
++ libsystemd_internal_sources,
+ include_directories : includes,
+ dependencies : libshared_deps)