summaryrefslogtreecommitdiff
path: root/sys-boot/silo/silo-1.4.14_p20200602.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/silo/silo-1.4.14_p20200602.ebuild')
-rw-r--r--sys-boot/silo/silo-1.4.14_p20200602.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/sys-boot/silo/silo-1.4.14_p20200602.ebuild b/sys-boot/silo/silo-1.4.14_p20200602.ebuild
index deeed7b293d6..6e6b9cd4d3f2 100644
--- a/sys-boot/silo/silo-1.4.14_p20200602.ebuild
+++ b/sys-boot/silo/silo-1.4.14_p20200602.ebuild
@@ -33,24 +33,30 @@ src_prepare() {
sed -i -e '/^ $(STRIP) ieee32.b/d' first/Makefile || die
}
+_emake() {
+ # We inject '-m32' / '-m elf32_sparc' to follow 'Rules.make' defaults.
+
+ emake \
+ HOSTCC="$(tc-getBUILD_CC)" \
+ CC="$(tc-getCC) -m32" \
+ STRIP="$(tc-getSTRIP)" \
+ NM="$(tc-getNM)" \
+ LD="$(tc-getLD) -m elf32_sparc" \
+ TILO_ONLY=$(usex tilo-only yes no) \
+ \
+ "$@"
+}
+
src_compile() {
filter-flags "-fstack-protector"
- CC="$(tc-getCC)" \
- STRIP="$(tc-getSTRIP)" \
- NM="$(tc-getNM)" \
- LD="$(tc-getLD)" \
- emake $(usex tilo-only '-C tilo' '')
+ _emake
}
src_install() {
- default
+ _emake DESTDIR="${D}" install
dodoc first-isofs/README.SILO_ISOFS docs/README*
-
- # Fix maketilo manpage
- rm "${D}"/usr/share/man/man1/maketilo.1
- dosym tilo.1 /usr/share/man/man1/maketilo.1
}
pkg_postinst() {