summaryrefslogtreecommitdiff
path: root/sys-boot/lilo/lilo-24.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/lilo/lilo-24.2-r1.ebuild')
-rw-r--r--sys-boot/lilo/lilo-24.2-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-boot/lilo/lilo-24.2-r1.ebuild b/sys-boot/lilo/lilo-24.2-r1.ebuild
index 66040236a6d6..a1e7a24913fd 100644
--- a/sys-boot/lilo/lilo-24.2-r1.ebuild
+++ b/sys-boot/lilo/lilo-24.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit flag-o-matic toolchain-funcs
+inherit flag-o-matic optfeature toolchain-funcs
DOLILO_V="0.6"
IUSE="static minimal pxeserial device-mapper"
@@ -184,4 +184,7 @@ pkg_postinst() {
einfo "edit /etc/conf.d/dolilo to harness its full potential."
echo
fi
+
+ optfeature "automatically updating lilo's configuration on each kernel installation" \
+ "sys-kernel/installkernel[-systemd]"
}