summaryrefslogtreecommitdiff
path: root/sys-boot/aboot
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/aboot')
-rw-r--r--sys-boot/aboot/Manifest1
-rw-r--r--sys-boot/aboot/aboot-9999.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-boot/aboot/Manifest b/sys-boot/aboot/Manifest
index 73e92ce9c03b..f0d8b71bdee0 100644
--- a/sys-boot/aboot/Manifest
+++ b/sys-boot/aboot/Manifest
@@ -8,4 +8,5 @@ DIST aboot-1.0_pre20040408.tar.bz2 115062 BLAKE2B 49f1b45abcd4726fd036e24709d10b
DIST aboot_gentoo.diff.bz2 9527 BLAKE2B 2492b456f7411630b6ecfb19db775969b69a35c0ef31b2146fd353aac78cf4d3c9ef2162cf54ab4ac025c65607219b3a33a74d2105be196e6dda54dd2509c1f8 SHA512 868a73fee56e9bf6d986175a6a4dc321ed12fb78d74dfb8f1a3e35274577ddc9ea0820768b44836403587b3976ad8dacdcf6562a9ce5c45981c752670901155f
DIST gentoo-headers-base-2.6.22.tar.bz2 4700338 BLAKE2B a264d7999ed7735e42ea21f8cf96b60ca1bdbfcb76dbdfcba14a849043e1f6a9109cd72bf5b91b9ab877dc3025ce6a9270ea914cf277b8f77cecff703646a7ec SHA512 99849928eede0c4b101ddc9179c0974cac6b4f18803dc98b72dcbe80cea88d3062f709beaa1b890edbed9c147be0dd516065d4cee945164b5d9f19f7a3cf249d
EBUILD aboot-1.0_pre20040408-r3.ebuild 2643 BLAKE2B 42cc709c24a16cc6a1edde9833894159a8f16b3ccd0328148b03dba0fe04e3f42ea66616c999e974fd82c13a0df587ff8fbad8e0ad5d0460e67abd20f7742b90 SHA512 4a86c1b908e70c83ef306c756bab15fe7a36cfb2677b178334deaea6f46cc391b5a743a5b2ab4d5cddaf7675ca7a75645a50ab5f11e4cf3327776848e4df5d89
+EBUILD aboot-9999.ebuild 1918 BLAKE2B 32d15635932447d804c78f47d8f8795cad5a96a6fb3088ffb479a07c90a4b27da48d7a187b09d9b90e668e0b9479d781cd9eddf59d05861b66815efa5a281e16 SHA512 ae87fa7a82b75160bdcbed66aa7d4a751fc261277063d1f6cf24174d62a5960587d7cb4be986b57a3d2ed1ce5a9c8c6b5ab811ed81064ab1ab79a7573608a0f2
MISC metadata.xml 338 BLAKE2B 7d68dddf2bf27051683da2c5f6a43ea7b3aa41b7e6bdbb8705d422e0db65b781d181cdc506a58824f4624985e72e82640b3bca51e46e6092cc2fdc047d38dcaa SHA512 2c9c87a850f9900d030fd37a4f59308136f478db254fbfd8e37d4f3c16ab33c74d1ef4119b74f4e0b34310ef066ffb53f89e2a4013cfca4a7b56f690e2aa7faf
diff --git a/sys-boot/aboot/aboot-9999.ebuild b/sys-boot/aboot/aboot-9999.ebuild
new file mode 100644
index 000000000000..d3e6321ec031
--- /dev/null
+++ b/sys-boot/aboot/aboot-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mattst88/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/anholt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="-* ~alpha"
+fi
+
+DESCRIPTION="Alpha Linux boot loader for SRM"
+HOMEPAGE="https://github.com/mattst88/aboot https://sourceforge.net/projects/aboot/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+BDEPEND="app-text/docbook-sgml-utils"
+
+src_compile() {
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) \
+ all netabootwrap
+
+ einfo "Building man pages"
+ emake -C doc/man
+}
+
+src_install() {
+ dodir /boot /sbin /usr/share/man/man{1,5,8}
+ emake root="${D}" install
+
+ insinto /boot
+ doins net_aboot.nh
+ dobin netabootwrap
+ dodoc ChangeLog INSTALL README TODO aboot.conf
+
+ insinto /etc
+ newins "${FILESDIR}"/aboot.conf aboot.conf.example
+
+}
+
+pkg_postinst() {
+ einfo "To make aboot install a new bootloader on your harddisk follow"
+ einfo "these steps:"
+ einfo ""
+ einfo " - edit the file /etc/aboot.conf"
+ einfo " - cd /boot"
+ einfo " - swriteboot -c2 /dev/sda bootlx"
+ einfo " This will install a new bootsector on /dev/sda and aboot will"
+ einfo " use the second partition on this device to lookup kernel and "
+ einfo " initrd (as described in the aboot.conf file)"
+ einfo ""
+ einfo "IMPORTANT :"
+ einfo ""
+ einfo "The partition table of your boot device has to contain "
+ einfo "a BSD-DISKLABEL and the first 12 megabytes of your boot device"
+ einfo "must not be part of a partition as aboot will write its bootloader"
+ einfo "in there and not as with most x86 bootloaders into the "
+ einfo "master boot sector. If your partition table does not reflect this"
+ einfo "you are going to destroy your installation !"
+ einfo "Also note that aboot currently only supports ext2/3 partitions"
+ einfo "to boot from."
+}