summaryrefslogtreecommitdiff
path: root/sys-block/sedutil/sedutil-1.20.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/sedutil/sedutil-1.20.0.ebuild')
-rw-r--r--sys-block/sedutil/sedutil-1.20.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-block/sedutil/sedutil-1.20.0.ebuild b/sys-block/sedutil/sedutil-1.20.0.ebuild
new file mode 100644
index 000000000000..07ea9f298216
--- /dev/null
+++ b/sys-block/sedutil/sedutil-1.20.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="The Drive Trust Alliance Self Encrypting Drive Utility"
+HOMEPAGE="https://github.com/Drive-Trust-Alliance/sedutil"
+SRC_URI="https://github.com/Drive-Trust-Alliance/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+src_prepare() {
+ default
+ # https://github.com/Drive-Trust-Alliance/sedutil/pull/49
+ sed 's: -Werror: :g' \
+ -i configure.ac \
+ -i Makefile.am || die
+ eautoreconf
+}