summaryrefslogtreecommitdiff
path: root/sys-block/rts_pstor
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/rts_pstor')
-rw-r--r--sys-block/rts_pstor/Manifest3
-rw-r--r--sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch36
-rw-r--r--sys-block/rts_pstor/rts_pstor-1.10_p20160103.ebuild3
3 files changed, 40 insertions, 2 deletions
diff --git a/sys-block/rts_pstor/Manifest b/sys-block/rts_pstor/Manifest
index 7d1480cadce2..febfd9a3b073 100644
--- a/sys-block/rts_pstor/Manifest
+++ b/sys-block/rts_pstor/Manifest
@@ -1,4 +1,5 @@
+AUX fix-compile-kernel-5.0.0.patch 716 BLAKE2B ecb1bbdaf80d7e801f6e316308f559f29b4f0a5a431dc74aea82fd771e4ba31945ed77b5041398c0bee144f7912e89c91b55f29158e866dbde3687c50425c1c0 SHA512 5eeb472b97ca4742358e6002afc3d7839b1d25d0e08e72badf0447b0d951b2950c195a9120288b377a45ea118af754b5418a7ff251b463df457a1c201cc5d107
AUX rts_pstor-makefile.patch 319 BLAKE2B afb25a7184c13b90fd9babf975cfc7710d4e643aad97994ff5d2f4f9bf77fc9928a1a2391890723e10c51107ad0cf4a5919418a9cb0787885d57de5e9cb08b03 SHA512 ae6b3890edef023d9b965d765baf7aefa75b0b44d51296f4997b0bb20a41c6a0d6ee19381a3d9194c23198b59da2a4523a1547363e3c82ba27c3625009f8d8ca
DIST rts_pstor-1.10_p20160103.tar.gz 108102 BLAKE2B 9cbca345211f7c99c6d9cf71b0ed207a4c911569eee6c63bfbe15c094be08f64c4550f04d9df688969f43564b2ff6a91d5cc72b8ab281cfdffb6884688b354de SHA512 d802a52b1e2da447a218472e77ca6ecc56e3b3767e3eb8daf634152675171c79c86e3b5ca9654b67cf32f63740c347bf7ecee5a1d20eb1c15a3a2ad3e9774311
-EBUILD rts_pstor-1.10_p20160103.ebuild 1342 BLAKE2B b649f3ac801ab6fb1711fc13c8660a3ced1aba39d29c362487d9b1dd8b2efea8af04900ce1fdeef44c9a82f44f99e25228cb6a4643ba27396ae35f0877fdf111 SHA512 e6d936d860a7934e20cfc6fc85a3602649d98683d83c4b2fd303dcee084d0ad4e006377d0e1ff279a5a1411c030f72510fd5a6664cb7bf2486a2c26a7c757bf8
+EBUILD rts_pstor-1.10_p20160103.ebuild 1388 BLAKE2B d4b8ed4a1a796283a275ebc152f5ab24423cf2739194853684f0797f355815003ed5b2a31b4c63c347fd8a41255dc866d15d8debd7f8d596c55c7126f7627a29 SHA512 7281a71816d36acf67f2a70275a49956b8f555c61eb411576caee572a3e7c18c5ab2da2d54cf0fd5fa27f55ed54b2373a282ef82e5a8a8f62c52f473dacfad6e
MISC metadata.xml 433 BLAKE2B 68ad81664e636facb6f248effc7c3ef58ea0c3cc86cc306b0862113665a296bcffe4df996861367eb98e26589c6124282a75d193fe1b84e90cbce12819b9279f SHA512 ef139e88440c4ad838b50a762373588a832dd4230596034399cb1b2fbb246a1fe957c8af86d98d80918fa747f2a0abad960af8a5144acbcd808dc956a833515b
diff --git a/sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch b/sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch
new file mode 100644
index 000000000000..7ea6ba6fd26b
--- /dev/null
+++ b/sys-block/rts_pstor/files/fix-compile-kernel-5.0.0.patch
@@ -0,0 +1,36 @@
+--- a/rtsx.h
++++ b/rtsx.h
+@@ -81,6 +81,17 @@
+ pci_get_domain_bus_and_slot(0, (bus), (devfn))
+ #endif
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 0, 0)
++static void do_gettimeofday(struct timeval *tv)
++{
++ struct timespec64 now;
++
++ ktime_get_real_ts64(&now);
++ tv->tv_sec = now.tv_sec;
++ tv->tv_usec = now.tv_nsec / 1000;
++}
++#endif
++
+ /*
+ * macros for easy use
+ */
+--- a/rtsx.c
++++ b/rtsx.c
+@@ -300,11 +300,13 @@
+
+ .max_sectors = 240,
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 0, 0)
+ /* merge commands... this seems to help performance, but
+ * periodically someone should test to see which setting is more
+ * optimal.
+ */
+ .use_clustering = 1,
++#endif
+
+
+ .emulated = 1,
diff --git a/sys-block/rts_pstor/rts_pstor-1.10_p20160103.ebuild b/sys-block/rts_pstor/rts_pstor-1.10_p20160103.ebuild
index 73c7c69315d7..e9b31fc3584d 100644
--- a/sys-block/rts_pstor/rts_pstor-1.10_p20160103.ebuild
+++ b/sys-block/rts_pstor/rts_pstor-1.10_p20160103.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2018 Gentoo Authors
+# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,6 +18,7 @@ KEYWORDS="~amd64 ~x86"
DEPEND="virtual/linux-sources"
PATCHES=(
"${FILESDIR}/rts_pstor-makefile.patch"
+ "${FILESDIR}/fix-compile-kernel-5.0.0.patch"
)
S="${WORKDIR}/RTS5209-linux-driver-${GIT_COMMIT}"