summaryrefslogtreecommitdiff
path: root/sys-block/ndctl/ndctl-71.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/ndctl/ndctl-71.1-r2.ebuild')
-rw-r--r--sys-block/ndctl/ndctl-71.1-r2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sys-block/ndctl/ndctl-71.1-r2.ebuild b/sys-block/ndctl/ndctl-71.1-r2.ebuild
new file mode 100644
index 000000000000..d6c230f369cd
--- /dev/null
+++ b/sys-block/ndctl/ndctl-71.1-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="Helper tools and libraries for managing non-volatile memory on Linux"
+HOMEPAGE="https://github.com/pmem/ndctl"
+SRC_URI="https://github.com/pmem/ndctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT CC0-1.0"
+SLOT="0/6"
+KEYWORDS="amd64 ~x86"
+IUSE="bash-completion systemd test"
+
+DEPEND="
+ dev-libs/json-c:=
+ sys-apps/keyutils:=
+ sys-apps/kmod:=
+ sys-apps/util-linux:=
+ virtual/libudev:=
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+# tests require root access
+RESTRICT+=" test"
+
+DOCS=(
+ README.md
+ CONTRIBUTING.md
+)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-71.1-bash-completion-configure.patch"
+)
+
+src_prepare() {
+ default
+ printf 'm4_define([GIT_VERSION], [%s])' "${PV}" > version.m4 || die
+ sed -e '/git-version-gen/ d' -i Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-bash-completion-dir="$(get_bashcompdir)" \
+ $(use_with systemd) \
+ --disable-asciidoctor
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ bashcomp_alias ndctl daxctl
+}