summaryrefslogtreecommitdiff
path: root/sys-block/ndctl/ndctl-71.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/ndctl/ndctl-71.1-r1.ebuild')
-rw-r--r--sys-block/ndctl/ndctl-71.1-r1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/sys-block/ndctl/ndctl-71.1-r1.ebuild b/sys-block/ndctl/ndctl-71.1-r1.ebuild
deleted file mode 100644
index 4f2aa941c70a..000000000000
--- a/sys-block/ndctl/ndctl-71.1-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools bash-completion-r1
-
-DESCRIPTION="Helper tools and libraries for managing non-volatile memory on Linux"
-HOMEPAGE="https://github.com/pmem/ndctl"
-SRC_URI="https://github.com/pmem/ndctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1 MIT CC0-1.0"
-SLOT="0/6"
-KEYWORDS="amd64 ~x86"
-IUSE="bash-completion systemd test"
-
-DEPEND="
- dev-libs/json-c:=
- sys-apps/keyutils:=
- sys-apps/kmod:=
- sys-apps/util-linux:=
- virtual/libudev:=
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- app-text/asciidoc
- app-text/xmlto
- sys-devel/libtool
- virtual/pkgconfig
-"
-
-RESTRICT="!test? ( test )"
-
-# tests require root access
-RESTRICT+=" test"
-
-DOCS=(
- README.md
- CONTRIBUTING.md
-)
-
-src_prepare() {
- default
- printf 'm4_define([GIT_VERSION], [%s])' "${PV}" > version.m4 || die
- sed -e '/git-version-gen/ d' -i Makefile.am || die
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_with bash-completion bash) \
- $(use_with systemd) \
- --disable-asciidoctor
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- use bash-completion && bashcomp_alias ndctl daxctl
-}