summaryrefslogtreecommitdiff
path: root/sys-block/megarc/megarc-1.11-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/megarc/megarc-1.11-r3.ebuild')
-rw-r--r--sys-block/megarc/megarc-1.11-r3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-block/megarc/megarc-1.11-r3.ebuild b/sys-block/megarc/megarc-1.11-r3.ebuild
new file mode 100644
index 000000000000..096122d4a4f7
--- /dev/null
+++ b/sys-block/megarc/megarc-1.11-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit multilib
+
+MY_PN="ut_linux_megarc"
+MY_PV="${PV//./-}"
+MY_P="${MY_PN}_${MY_PV}"
+
+DESCRIPTION="LSI Logic MegaRAID Text User Interface management tool"
+# Previous releases from LSI directly required a click-through EULA; but the
+# upstream website no longer requires this consistently: most old files have
+# two or more download pages, and while one of the pages has a generic
+# click-through download form, the file-specific download page only requires
+# click-through on some items. See also sys-block/lsiutil, sys-block/megarc
+# 2022/03/19: robbat2 confirms the SRC_URI links work AND the files have not changed upstream
+HOMEPAGE="http://www.avagotech.com/cs/Satellite?q=megacli&pagename=AVG2%2FsearchLayout&locale=avg_en&within=megacli&Search=megarc&srch-radio=new&Submit=Search"
+SRC_URI="
+ https://docs.broadcom.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/${MY_P}.zip
+ https://docs.broadcom.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/README_FOR_${MY_P}-zip.txt"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip
+ doc? ( app-text/antiword )"
+RDEPEND=""
+
+RESTRICT="mirror bindist"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/opt/bin/megarc"
+
+pkg_setup() {
+ use amd64 && { has_multilib_profile || die "needs multilib profile on amd64"; }
+}
+
+src_compile() {
+ use doc && antiword ut_linux.doc > ${PN}-manual.txt
+}
+
+src_install() {
+ use doc && dodoc ${PN}-manual.txt
+ newdoc ut_linux_${PN}_${PV}.txt ${PN}-release-${PV}.txt
+ newdoc "${DISTDIR}"/README_FOR_${MY_P}-zip.txt README
+
+ exeinto /opt/bin
+ newexe megarc.bin megarc
+}