summaryrefslogtreecommitdiff
path: root/sys-block/blktrace/blktrace-1.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/blktrace/blktrace-1.1.0-r1.ebuild')
-rw-r--r--sys-block/blktrace/blktrace-1.1.0-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sys-block/blktrace/blktrace-1.1.0-r1.ebuild b/sys-block/blktrace/blktrace-1.1.0-r1.ebuild
deleted file mode 100644
index 29c03c431b25..000000000000
--- a/sys-block/blktrace/blktrace-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs flag-o-matic linux-info
-
-MY_PN="blktrace"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue"
-HOMEPAGE="https://git.kernel.dk/cgit/blktrace/"
-SRC_URI="https://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="doc"
-
-RDEPEND="dev-libs/libaio"
-# This is a Linux specific app!
-DEPEND="${RDEPEND}
- sys-kernel/linux-headers
- doc? (
- virtual/latex-base
- >=app-text/texlive-core-2014
- )
-"
-S="${WORKDIR}/${MY_P}"
-
-CONFIG_CHECK="~BLK_DEV_IO_TRACE"
-WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.1.0-ldflags-parallel-make.patch )
-
-src_compile() {
- append-flags -DLVM_REMAP_WORKAROUND -W -I"${S}"
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
- if use doc; then
- export VARTEXFONTS="${T}/fonts"
- emake docs
- fi
-}
-
-src_install() {
- emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man"
- einstalldocs
- use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
-}