summaryrefslogtreecommitdiff
path: root/sys-auth
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/Manifest.gzbin10882 -> 10883 bytes
-rw-r--r--sys-auth/fingerprint-gui/Manifest2
-rw-r--r--sys-auth/fingerprint-gui/fingerprint-gui-1.09.ebuild114
-rw-r--r--sys-auth/oath-toolkit/Manifest3
-rw-r--r--sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-gcc7.patch80
-rw-r--r--sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild5
6 files changed, 202 insertions, 2 deletions
diff --git a/sys-auth/Manifest.gz b/sys-auth/Manifest.gz
index 2afd8d83f78b..e5f42dfd4c94 100644
--- a/sys-auth/Manifest.gz
+++ b/sys-auth/Manifest.gz
Binary files differ
diff --git a/sys-auth/fingerprint-gui/Manifest b/sys-auth/fingerprint-gui/Manifest
index 1eb3a8688f08..62b877fc5bf8 100644
--- a/sys-auth/fingerprint-gui/Manifest
+++ b/sys-auth/fingerprint-gui/Manifest
@@ -1,3 +1,5 @@
DIST fingerprint-gui-1.07.tar.gz 7042051 BLAKE2B c9b371e6344fd2a838a4c99a2962362a8aece8c3bce995926ff935453cf2d0d6b6b5f189e359638eb717bdba167b67d4ac336d7035646c7e68b62d5140e15c1d SHA512 b63bc86cbff29587a7fe164dd9344178006079f2520265ecd3d96e57bf584694246e17db780051dcacfe39dc6bd4da437b16e33d2f7cb6b474ae61dfbced6a3b
+DIST fingerprint-gui-1.09.tar.gz 7037943 BLAKE2B b35b8a1c5f53752709da44903961527c01db20773298e4636d8c316946cd7d23022c9407081c55ba5f6ec55d9ed53b7f8ef858c44a623873834fa1cbd6aa941f SHA512 c4fb22368d82d72586f80009b5adb9db0a8e8777c3d1c1f23cf58a21f718a3e3d05bbc90fff295be969cf7f744f037fb886e975e626cf6d599f8f6b5f8323724
EBUILD fingerprint-gui-1.07-r1.ebuild 2745 BLAKE2B bd8cb71565422b20c1f016c9a50291ea773aed36ceff562167fe32f5115b73604a60d08c1cd567627106c9e1540b6fb29d48c0d56ef054ae359fc799397ff48f SHA512 d453dc8840625ff1a94c0bc10431845f77149b9754b7f197c13c9019d00fee7b0f8e3854a044c1ff6104e57a2cdf3ebafa457654bd4eaf7cbf7473f0e27965e6
+EBUILD fingerprint-gui-1.09.ebuild 3184 BLAKE2B 4669bfee4fea1a002c4c2d42a27486db4cdbe073305cefc64d406c1180ac7a24a00605535f987cb2ca8cf480a25634bb5df2fb9b385fe122ca671abdb7121b17 SHA512 42d3d2d2fa5153a2b423be60078a45571a6afa082b69d7a67e2bd478fc9396b15c6f87d4cacbbe9e26fe97c57b969c299ea840e9a941f04e991387f3cdea3e37
MISC metadata.xml 343 BLAKE2B 9ee8b04222d90af96a3fcaac64416f5d286659f09d0a0cd2b00b252b6e2accb19fe88f37ba1ba87b81a83604a6f6fee71b84879af1bbad5f65af63d3a8450d31 SHA512 bb58875fd47a66a6784b088e3e2dcb07a89f61d48ff94547c4456e46f275d6c037f017632552ff4e43712b34d3fa2f8d5075e88c106f7cb6a72d317753522b7a
diff --git a/sys-auth/fingerprint-gui/fingerprint-gui-1.09.ebuild b/sys-auth/fingerprint-gui/fingerprint-gui-1.09.ebuild
new file mode 100644
index 000000000000..2d7b9377d7ca
--- /dev/null
+++ b/sys-auth/fingerprint-gui/fingerprint-gui-1.09.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils readme.gentoo-r1 udev user gnome2-utils
+
+DESCRIPTION="Use Fingerprint Devices with Linux"
+HOMEPAGE="http://www.ullrich-online.cc/fingerprint/ https://github.com/maksbotan/fingerprint-gui"
+SRC_URI="https://github.com/maksbotan/fingerprint-gui/archive/v${PV}-qt5.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+upekbsapi"
+
+DEPEND="
+ app-crypt/qca[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dev-qt/qtx11extras:5
+ sys-auth/libfprint
+ sys-auth/polkit-qt[qt5(+)]
+ sys-libs/pam
+ x11-libs/libX11
+ x11-proto/xproto
+ x11-libs/libfakekey
+ dev-libs/libusb
+ !sys-auth/thinkfinger
+"
+RDEPEND="${DEPEND}"
+
+QA_SONAME="/usr/lib/libbsapi.so.* /usr/lib64/libbsapi.so.*"
+QA_PRESTRIPPED="/usr/lib/libbsapi.so.* /usr/lib64/libbsapi.so.*"
+QA_FLAGS_IGNORED="/usr/lib/libbsapi.so.* /usr/lib64/libbsapi.so.*"
+
+S="${WORKDIR}/${P}-qt5"
+
+HTML_DOCS=( doc/Hacking.html doc/Step-by-step-manual.html )
+
+src_prepare() {
+ eapply_user
+
+ sed -e '/Icon=/s:=.*:=Fingerprint:' \
+ -i bin/${PN}/${PN}.desktop || die
+ sed -e "s:/etc/udev/rules.d:\"$(get_udevdir)\"/rules.d:g" \
+ -i bin/${PN%-gui}-helper/${PN%-gui}-helper.pro || die
+ sed -e 's:GROUP="plugdev":GROUP="fingerprint":' \
+ -i bin/fingerprint-helper/92-fingerprint-gui-uinput.rules \
+ -i upek/91-fingerprint-gui-upek.rules || die
+ sed -e '/DOCDIR\s\+=/s:'${PN}':'${PF}/html':' \
+ -i bin/fingerprint-gui/fingerprint-gui.pro || die
+ sed -e '/#define DOCDIR/s:'${PN}':'${PF}/html':' \
+ -i include/Globals.h || die
+}
+
+src_configure() {
+ eqmake5 \
+ PREFIX="${EROOT}"usr \
+ LIB="$(get_libdir)" \
+ LIBEXEC=libexec \
+ LIBPOLKIT_QT=LIBPOLKIT_QT_1_1
+}
+
+src_install() {
+ export INSTALL_ROOT="${D}" #submakes need it as well, re-install fails otherwise.
+ emake -j1 install
+ if use upekbsapi ; then
+ use amd64 && dolib.so upek/lib64/libbsapi.so*
+ use x86 && dolib.so upek/lib/libbsapi.so*
+ udev_dorules upek/91-fingerprint-gui-upek.rules
+ insinto /etc
+ doins upek/upek.cfg
+ #dodir /var/upek_data
+ #fowners root:plugdev /var/upek_data
+ #fperms 0775 /var/upek_data
+ fi
+ doicon src/res/Fingerprint.png
+
+ einstalldocs
+
+ keepdir /var/lib/fingerprint-gui
+
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ enewgroup fingerprint
+
+ gnome2_icon_cache_update
+}
+
+pkg_postinst() {
+ einfo "Fixing permisisons of fingerprints..."
+ find "${EROOT}"/var/lib/fingerprint-gui -exec chown root:root {} + || die "chown root:root failed"
+ find "${EROOR}"/var/lib/fingerprint-gui -type d -exec chmod 755 {} + || die "chmod 755 failed"
+ find "${EROOT}"/var/lib/fingerprint-gui -type f -exec chmod 600 {} + || die "chmod 600 failed"
+
+ readme.gentoo_print_elog
+
+ gnome2_icon_cache_update
+}
+
+FORCE_PRINT_ELOG=1
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="Please take a thorough look a the Step-by-step-manual.html
+in /usr/share/doc/${PF}/html for integration with pam/polkit/...
+Hint: You may want
+ auth sufficient pam_fingerprint-gui.so
+in /etc/pam.d/system-auth
+
+There are udev rules to enforce group fingerprint on the reader device
+Please put yourself in that group and re-trigger the udev rules."
diff --git a/sys-auth/oath-toolkit/Manifest b/sys-auth/oath-toolkit/Manifest
index 02d200d7f6fa..62b98c6de795 100644
--- a/sys-auth/oath-toolkit/Manifest
+++ b/sys-auth/oath-toolkit/Manifest
@@ -1,5 +1,6 @@
+AUX oath-toolkit-2.6.2-gcc7.patch 3526 BLAKE2B 07966d96b4362cb7c271fa745cf9be843e14db9cade77768a9f31bbb0435c4f1f56c81464630871ad337213cbdc97ed0c1cf9ad9d261e29812984bab767c1eb1 SHA512 4bf9bc8e176861f044c55aab6c6cb48dcd7ac1d887f71f08475cc1e7f2b14cb04edc8417532613433af35687169667b073ea57556c85114e5a763a03443a85b9
DIST oath-toolkit-2.6.1.tar.gz 4238966 BLAKE2B 7af4f4997b18278aa1903470c79e5a7734e9e97e62a2de4685eee58ead59e3294cef0d6da0147746932a2891f59648b5473f02b5edd6c4fd81b4a9c80d9bde60 SHA512 59feadbc06d11a52bf5879493227c40358fc1f4f17ec3ff92e3a313e47b92f3154396fa3ff38ef163852b32c8bfcef1f59753b614d0138478b8f7e7971f55e62
DIST oath-toolkit-2.6.2.tar.gz 4295786 BLAKE2B 2b97ab73339647b560b46373922095f18655a167b613b15d4ee2fd507d430025628d20eb111ff1d8025e78646b1d61d9680a7082caba1c75d247bb1d8b9b99dd SHA512 201a702a05a2e9fb3a66d04750e1a34e293342126caf02c344954a0d9fd0daafe73ca7f1fe273be129ae555a29b82b72fa2b4770ea2ad10711924e1926ec2cfb
EBUILD oath-toolkit-2.6.1.ebuild 1456 BLAKE2B cf19d07cdb90a67e55e581593b5819ad9c4d75e0751afc21db7dd0dda4dc6d239b3d43bd377106591af4769edc36ed12b8a90b6cc47fa1183d3babde017d67fb SHA512 0c03c380e36070e9030575d63435554ec573cd0ea75bb87bc28cfda3e5a8ca10c025fdc6b14f670a3db200c78064ff12e92db4b8ae1f935c71b778728ffab414
-EBUILD oath-toolkit-2.6.2.ebuild 1456 BLAKE2B a72b3849e006231217d22a37fad2940fb1d73a069bb85da01507f4a71d3a5d0b211c148652e70b6ee6afd1c32f470a7ba8cc81dc2c247c837ab10ecb98448573 SHA512 5f60d1848f704a7c01401ec42f11cb3f509747e87b69e08b0ab5edcc68d5d8c0e8c19f1f4ab9cb275b8e804b88701dd1810bad7331450cafe282fb828eb48a9d
+EBUILD oath-toolkit-2.6.2.ebuild 1500 BLAKE2B 5f0202b63c0eddd14763d8281200eafe7361336d2c1e5fa34be0a61c95d18d5eb5b80fe5ab52c103bfd5b7223126e6fb9d177fb923dd8f896bae749962210bf6 SHA512 d0225d4edaf4890bc22aa03e3835f85ff8137af525a874369eaf2880b76bf424ad2ecb0ea0da7163d9896307508ddf4091660ac4cfef283adc2e791547792beb
MISC metadata.xml 560 BLAKE2B 946cac9a0134fb3291ad816283326746067411e000e98be05cd8f87dfa0455ef3558b1bdabcb537356fed867d8667850d929747592e7c79212c7ad3357434c84 SHA512 4d6506e02bb4a6f6069dfe357cc3e05c897699a067771baa995af823d4de587d2580b01bf1c2a38cb8f8f679ba0702498ad904b6bb1d685a2759c2b7752be7f2
diff --git a/sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-gcc7.patch b/sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-gcc7.patch
new file mode 100644
index 000000000000..18a0a2779408
--- /dev/null
+++ b/sys-auth/oath-toolkit/files/oath-toolkit-2.6.2-gcc7.patch
@@ -0,0 +1,80 @@
+Bug: https://bugs.gentoo.org/618100
+Cherry-picked from upstream commits: https://github.com/coreutils/gnulib/commit/175b4e22f99e00996b72f822f5ae54dca8243d19
+ https://github.com/coreutils/gnulib/commit/abae112b34572cd3869ce4fc81dddb5c2a7394c4
+
+--- a/oathtool/gl/intprops.h
++++ b/oathtool/gl/intprops.h
+@@ -23,6 +23,10 @@
+ #include <limits.h>
+ #include <verify.h>
+
++#ifndef __has_builtin
++# define __has_builtin(x) 0
++#endif
++
+ /* Return a value with the common real type of E and V and the value of V. */
+ #define _GL_INT_CONVERT(e, v) (0 * (e) + (v))
+
+@@ -222,20 +226,24 @@
+ ? (a) < (min) >> (b) \
+ : (max) >> (b) < (a))
+
+-/* True if __builtin_add_overflow (A, B, P) works when P is null. */
+-#define _GL_HAS_BUILTIN_OVERFLOW_WITH_NULL (7 <= __GNUC__)
++/* True if __builtin_add_overflow (A, B, P) works when P is non-null. */
++#define _GL_HAS_BUILTIN_OVERFLOW \
++ (5 <= __GNUC__ || __has_builtin (__builtin_add_overflow))
++
++#define _GL_HAS_BUILTIN_OVERFLOW_P \
++ (7 <= __GNUC__ || __has_builtin (__builtin_add_overflow_p))
+
+ /* The _GL*_OVERFLOW macros have the same restrictions as the
+ *_RANGE_OVERFLOW macros, except that they do not assume that operands
+ (e.g., A and B) have the same type as MIN and MAX. Instead, they assume
+ that the result (e.g., A + B) has that type. */
+-#if _GL_HAS_BUILTIN_OVERFLOW_WITH_NULL
+-# define _GL_ADD_OVERFLOW(a, b, min, max)
+- __builtin_add_overflow (a, b, (__typeof__ ((a) + (b)) *) 0)
+-# define _GL_SUBTRACT_OVERFLOW(a, b, min, max)
+- __builtin_sub_overflow (a, b, (__typeof__ ((a) - (b)) *) 0)
+-# define _GL_MULTIPLY_OVERFLOW(a, b, min, max)
+- __builtin_mul_overflow (a, b, (__typeof__ ((a) * (b)) *) 0)
++#if _GL_HAS_BUILTIN_OVERFLOW_P
++# define _GL_ADD_OVERFLOW(a, b, min, max) \
++ __builtin_add_overflow_p (a, b, (a) + (b))
++# define _GL_SUBTRACT_OVERFLOW(a, b, min, max) \
++ __builtin_sub_overflow_p (a, b, (a) - (b))
++# define _GL_MULTIPLY_OVERFLOW(a, b, min, max) \
++ __builtin_mul_overflow_p (a, b, (a) * (b))
+ #else
+ # define _GL_ADD_OVERFLOW(a, b, min, max) \
+ ((min) < 0 ? INT_ADD_RANGE_OVERFLOW (a, b, min, max) \
+@@ -315,7 +323,7 @@
+ _GL_BINARY_OP_OVERFLOW (a, b, _GL_ADD_OVERFLOW)
+ #define INT_SUBTRACT_OVERFLOW(a, b) \
+ _GL_BINARY_OP_OVERFLOW (a, b, _GL_SUBTRACT_OVERFLOW)
+-#if _GL_HAS_BUILTIN_OVERFLOW_WITH_NULL
++#if _GL_HAS_BUILTIN_OVERFLOW || _GL_HAS_BUILTIN_OVERFLOW_P
+ # define INT_NEGATE_OVERFLOW(a) INT_SUBTRACT_OVERFLOW (0, a)
+ #else
+ # define INT_NEGATE_OVERFLOW(a) \
+@@ -349,10 +357,6 @@
+ #define INT_MULTIPLY_WRAPV(a, b, r) \
+ _GL_INT_OP_WRAPV (a, b, r, *, __builtin_mul_overflow, INT_MULTIPLY_OVERFLOW)
+
+-#ifndef __has_builtin
+-# define __has_builtin(x) 0
+-#endif
+-
+ /* Nonzero if this compiler has GCC bug 68193 or Clang bug 25390. See:
+ https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68193
+ https://llvm.org/bugs/show_bug.cgi?id=25390
+@@ -369,7 +373,7 @@
+ the operation. BUILTIN is the builtin operation, and OVERFLOW the
+ overflow predicate. Return 1 if the result overflows. See above
+ for restrictions. */
+-#if 5 <= __GNUC__ || __has_builtin (__builtin_add_overflow)
++#if _GL_HAS_BUILTIN_OVERFLOW
+ # define _GL_INT_OP_WRAPV(a, b, r, op, builtin, overflow) builtin (a, b, r)
+ #elif 201112 <= __STDC_VERSION__ && !_GL__GENERIC_BOGUS
+ # define _GL_INT_OP_WRAPV(a, b, r, op, builtin, overflow) \
diff --git a/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild b/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild
index 394a6ea3c5f9..f3d38999c1e5 100644
--- a/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild
+++ b/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild
@@ -20,7 +20,11 @@ DEPEND="${RDEPEND}
test? ( dev-libs/libxml2 )
dev-util/gtk-doc-am"
+PATCHES=( "${FILESDIR}"/${P}-gcc7.patch )
+
src_prepare() {
+ default
+
# These tests need git/cvs and don't reflect anything in the final app
sed -i -r \
-e '/TESTS/s,test-vc-list-files-(git|cvs).sh,,g' \
@@ -30,7 +34,6 @@ src_prepare() {
-e '/AM_INIT_AUTOMAKE/ s:-Wall:\0 -Wno-portability:' \
{liboath,libpskc}/configure.ac
eautoreconf
- default
}
src_configure() {