summaryrefslogtreecommitdiff
path: root/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild')
-rw-r--r--sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild b/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
index 5148727daa45..d877ef488e97 100644
--- a/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
+++ b/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-info pam
+inherit autotools linux-info pam
DESCRIPTION="Support for the UPEK/SGS Thomson fingerprint reader, common in Thinkpads"
HOMEPAGE="http://thinkfinger.sourceforge.net/"
@@ -28,6 +28,8 @@ PATCHES=(
"${FILESDIR}"/${PV}-send-sync-event.patch
"${FILESDIR}"/${PV}-tftoolgroup.patch
"${FILESDIR}"/${PV}-strip-strip.patch
+ "${FILESDIR}"/${PV}-autoreconf.patch
+ "${FILESDIR}"/${PV}-slibtool.patch
)
pkg_setup() {
@@ -38,6 +40,11 @@ pkg_setup() {
fi
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
--disable-static \