summaryrefslogtreecommitdiff
path: root/sys-auth/seatd/seatd-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/seatd/seatd-9999.ebuild')
-rw-r--r--sys-auth/seatd/seatd-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-auth/seatd/seatd-9999.ebuild b/sys-auth/seatd/seatd-9999.ebuild
index c826e115f27c..8513ea785669 100644
--- a/sys-auth/seatd/seatd-9999.ebuild
+++ b/sys-auth/seatd/seatd-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson systemd
@@ -11,7 +11,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
else
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="MIT"
@@ -34,10 +34,12 @@ src_configure() {
$(meson_feature server)
)
- if use elogind || use systemd; then
- emesonargs+=( -Dlogind=enabled )
+ if use elogind ; then
+ emesonargs+=( -Dlibseat-logind=elogind )
+ elif use systemd; then
+ emesonargs+=( -Dlibseat-logind=systemd )
else
- emesonargs+=( -Dlogind=disabled )
+ emesonargs+=( -Dlibseat-logind=disabled )
fi
meson_src_configure