summaryrefslogtreecommitdiff
path: root/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r1.ebuild')
-rw-r--r--sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r1.ebuild b/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r1.ebuild
new file mode 100644
index 000000000000..1f0ef021b4cf
--- /dev/null
+++ b/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Rules for polkit to add compatibility with pklocalauthority"
+HOMEPAGE="https://pagure.io/polkit-pkla-compat"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+
+RDEPEND=">=dev-libs/glib-2.30
+ >=sys-auth/polkit-0.110"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ fowners -R root:polkitd /etc/polkit-1/localauthority
+}
+
+pkg_postinst() {
+ chown -R root:polkitd "${EROOT}"/etc/polkit-1/localauthority || die
+}