summaryrefslogtreecommitdiff
path: root/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_p11/pam_p11-0.2.0.ebuild')
-rw-r--r--sys-auth/pam_p11/pam_p11-0.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-auth/pam_p11/pam_p11-0.2.0.ebuild b/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
new file mode 100644
index 000000000000..5719fc04d4c4
--- /dev/null
+++ b/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune pam
+
+DESCRIPTION="PAM module for authenticating against PKCS#11 tokens"
+HOMEPAGE="https://github.com/opensc/pam_p11/wiki"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/pam
+ dev-libs/libp11
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --with-pamdir="$(getpam_mod_dir)"
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}