summaryrefslogtreecommitdiff
path: root/sys-auth/fprintd/fprintd-0.8.1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/fprintd/fprintd-0.8.1-r3.ebuild')
-rw-r--r--sys-auth/fprintd/fprintd-0.8.1-r3.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/sys-auth/fprintd/fprintd-0.8.1-r3.ebuild b/sys-auth/fprintd/fprintd-0.8.1-r3.ebuild
index 897c45965ff9..42c82b1510e9 100644
--- a/sys-auth/fprintd/fprintd-0.8.1-r3.ebuild
+++ b/sys-auth/fprintd/fprintd-0.8.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,25 +13,28 @@ SRC_URI="https://cgit.freedesktop.org/libfprint/${PN}/snapshot/${MY_PV}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc pam static-libs"
+IUSE="doc pam"
RDEPEND="
dev-libs/dbus-glib
dev-libs/glib:2
sys-auth/libfprint:0
sys-auth/polkit
- pam? ( sys-libs/pam )
-"
+ pam? ( sys-libs/pam )"
DEPEND="${RDEPEND}"
BDEPEND="
dev-libs/dbus-glib
dev-util/gtk-doc
dev-util/gtk-doc-am
dev-util/intltool
- doc? ( dev-libs/libxml2 dev-libs/libxslt )
-"
+ doc? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )"
-S=${WORKDIR}/${MY_PV}
+S="${WORKDIR}"/${MY_PV}
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_prepare() {
default
@@ -42,8 +45,8 @@ src_prepare() {
src_configure() {
econf \
+ --disable-static \
$(use_enable pam) \
- $(use_enable static-libs static) \
$(use_enable doc gtk-doc-html) \
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
}
@@ -54,7 +57,7 @@ src_install() {
keepdir /var/lib/fprint
- find "${ED}" -type f -name "*.la" -delete || die
+ find "${ED}" -name '*.la' -delete || die
dodoc AUTHORS NEWS README{,.transifex} TODO
newdoc pam/README README.pam_fprintd