summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/Manifest.gzbin49195 -> 49368 bytes
-rw-r--r--sys-apps/polychromatic/Manifest4
-rw-r--r--sys-apps/polychromatic/metadata.xml21
-rw-r--r--sys-apps/polychromatic/polychromatic-0.7.3.ebuild67
-rw-r--r--sys-apps/polychromatic/polychromatic-9999.ebuild67
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/Manifest2
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-43.0.ebuild39
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest2
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.15.0.ebuild45
9 files changed, 247 insertions, 0 deletions
diff --git a/sys-apps/Manifest.gz b/sys-apps/Manifest.gz
index 93db9168c664..e41474efad00 100644
--- a/sys-apps/Manifest.gz
+++ b/sys-apps/Manifest.gz
Binary files differ
diff --git a/sys-apps/polychromatic/Manifest b/sys-apps/polychromatic/Manifest
new file mode 100644
index 000000000000..58f2cf612c55
--- /dev/null
+++ b/sys-apps/polychromatic/Manifest
@@ -0,0 +1,4 @@
+DIST polychromatic-0.7.3.tar.gz 1513522 BLAKE2B 85dab08c90843f050175de8b53c34dfab4c87dde6d7daaffb36bfad09e165aa8220a943b47ae7b09fb3c45589165051ae27b9c5e17f4c94479e6a8575b593ef4 SHA512 bdd816fcbae8ce2e12367afd455941afb754f7ddb9f6337c6b675a3059c1dc6d64b1a7809efce9b909b8aee2025b496dc0b870d2e56a09da7fde7f8b5d733c5f
+EBUILD polychromatic-0.7.3.ebuild 1830 BLAKE2B a6255d3f29e102b01cf0dc93602a3a0deb436749336bc03efdaa07962c6d4f27a642281f00bbe748cff17bab917d0994501082020da8ac46cad7b98cbcb1c0d1 SHA512 3dc664819f9ad58de02d12f601da59fb32cf8055309df7553c964ccabb48ed7f9a4e2f9388f76cde0fe072a25ffeb840c8a427f718e7eca9e08daf5077fbbeae
+EBUILD polychromatic-9999.ebuild 1830 BLAKE2B a6255d3f29e102b01cf0dc93602a3a0deb436749336bc03efdaa07962c6d4f27a642281f00bbe748cff17bab917d0994501082020da8ac46cad7b98cbcb1c0d1 SHA512 3dc664819f9ad58de02d12f601da59fb32cf8055309df7553c964ccabb48ed7f9a4e2f9388f76cde0fe072a25ffeb840c8a427f718e7eca9e08daf5077fbbeae
+MISC metadata.xml 889 BLAKE2B 8ce971727662be8955ae194838e8985876bdd6ee07c12b1587506bda595b57aaa7313dc5ba6c337c621dcfcbbe1b8519169469f99f0cf5878902330e9c8c5dbf SHA512 660d890d895e8edaef63dfa77ee02baab65388e5533ff82d15618d8d6bcdee0966e1087667b4b4cbe2ac2547549e6c0fba8c75587bf8fb83f31a1b047813c4b4
diff --git a/sys-apps/polychromatic/metadata.xml b/sys-apps/polychromatic/metadata.xml
new file mode 100644
index 000000000000..41de43439b95
--- /dev/null
+++ b/sys-apps/polychromatic/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Polychromatic is a vendor agnostic front-end for managing lighting, RGB
+ effects and some special functionality for keyboards, mice, keypads and
+ just about any other gaming peripheral on your GNU/Linux system. The
+ software aims to make it easy to create and co-ordinate lighting effects
+ that work across all compatible hardware, even if you switch to another
+ brand also supported by Polychromatic.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/polychromatic/polychromatic/-/issues/</bugs-to>
+ <remote-id type="gitlab">polychromatic/polychromatic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/polychromatic/polychromatic-0.7.3.ebuild b/sys-apps/polychromatic/polychromatic-0.7.3.ebuild
new file mode 100644
index 000000000000..83047579b56e
--- /dev/null
+++ b/sys-apps/polychromatic/polychromatic-0.7.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-single-r1 readme.gentoo-r1 xdg
+
+DESCRIPTION="RGB lighting management software for GNU/Linux powered by OpenRazer"
+HOMEPAGE="https://polychromatic.app/
+ https://github.com/polychromatic/polychromatic/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.20:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[svg,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/colour[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ sys-apps/openrazer[client,${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-util/intltool
+ dev-lang/sassc
+"
+
+DOC_CONTENTS="To automatically start up Polychromatic on session login copy
+/usr/share/polychromatic/polychromatic-autostart.desktop file into Your user's
+~/.config/autostart/ directory."
+
+src_install() {
+ meson_src_install
+ python_optimize
+ readme.gentoo_create_doc
+
+ # Do not force polychromatic to autostart on session login.
+ # Move it into /usr/share/polychromatic and treat it as an example file
+ # that could be installed into user's ~/.config/autostart/ directory.
+ mv "${ED}"/etc/xdg/autostart/${PN}-autostart.desktop \
+ "${ED}"/usr/share/${PN}/${PN}-autostart.desktop || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/sys-apps/polychromatic/polychromatic-9999.ebuild b/sys-apps/polychromatic/polychromatic-9999.ebuild
new file mode 100644
index 000000000000..83047579b56e
--- /dev/null
+++ b/sys-apps/polychromatic/polychromatic-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-single-r1 readme.gentoo-r1 xdg
+
+DESCRIPTION="RGB lighting management software for GNU/Linux powered by OpenRazer"
+HOMEPAGE="https://polychromatic.app/
+ https://github.com/polychromatic/polychromatic/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.20:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[svg,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/colour[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ sys-apps/openrazer[client,${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-util/intltool
+ dev-lang/sassc
+"
+
+DOC_CONTENTS="To automatically start up Polychromatic on session login copy
+/usr/share/polychromatic/polychromatic-autostart.desktop file into Your user's
+~/.config/autostart/ directory."
+
+src_install() {
+ meson_src_install
+ python_optimize
+ readme.gentoo_create_doc
+
+ # Do not force polychromatic to autostart on session login.
+ # Move it into /usr/share/polychromatic and treat it as an example file
+ # that could be installed into user's ~/.config/autostart/ directory.
+ mv "${ED}"/etc/xdg/autostart/${PN}-autostart.desktop \
+ "${ED}"/usr/share/${PN}/${PN}-autostart.desktop || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/sys-apps/xdg-desktop-portal-gnome/Manifest b/sys-apps/xdg-desktop-portal-gnome/Manifest
index 6b280044b72b..3faf30f287ae 100644
--- a/sys-apps/xdg-desktop-portal-gnome/Manifest
+++ b/sys-apps/xdg-desktop-portal-gnome/Manifest
@@ -1,3 +1,5 @@
DIST xdg-desktop-portal-gnome-42.3.tar.xz 119228 BLAKE2B 1cafeda9e9ad5431eb52520db19350e9ee4c9f65e0923f6f320561893a29e32fc5033f3da540dd492c3341a8cb6bf29687cbf04b027e68ee388d102ac7023cac SHA512 0704eb29af5464fa0598cb4a05451866c8bacc20ad0638f7e799e7abdb4bbd86c41efbad963c493767190ae55f9d9c5d28360ee5fbbe1c42881969d03c7e84f5
+DIST xdg-desktop-portal-gnome-43.0.tar.xz 123836 BLAKE2B 304655c999cf938de6cff23e190835d3a902dce81e64b041dfd2ceed817ec239cb67479dc3fca979659dc15d31acb12e36f38499408c6a063e412760f28266ac SHA512 57dc455b19fc0c22aac9fb9fab375964999e99d96d2c6452ffecde3081e3a5a860eaf04dbada5ed87d43ae35119d1ab4d4fdfce3d1a9dc54b20862166984c2b3
EBUILD xdg-desktop-portal-gnome-42.3.ebuild 830 BLAKE2B 856d89e8fb635f5747c36611bfdcd7b8be3e22567551c3782eefe031ae14c8477a534fc211002d68db87ff9842bf01e68958653b14b38620cdd745bdd576f464 SHA512 3e336678ed9103c04d21b9f8c1f09b987b20cefc33d957f9aecaa4d924080d5e06c5d8d316fa1c732e944e7204f2b129f29a4717fa7adf51a5aa59ee2a674b0c
+EBUILD xdg-desktop-portal-gnome-43.0.ebuild 836 BLAKE2B 4dd124fe920c5f8a8ff97fde3a6fce9db0ba103be50c6dac5df38122d0e53a2e7a4c26ff8df07335615b0e2c562938e3ed231b596f57a08010fa0d0de47e76fa SHA512 cbfb4ea7e1e7b7ce3441fc91c73175fc058e34ff5a5dcf3b42cb82ac42aad3d2dcf7b6157d77f9e91873979d40abac4f3935fdd91895dc5bf5636f7712339f8a
MISC metadata.xml 254 BLAKE2B de7a97001e5947704f42973c8a0c3a23c2d80afb976254f5fd21e9d372a946e055d4cdc3c0eaed010505f87929b56e8b1e650c945e2a302644adbc9440833be8 SHA512 c81da4f9b80e5691a167f4590906952e25356604ec17689c005be14efb394c0634776bbe84df936edde239480bdf46db41216b00da4a3a45f670e9ca18ab0132
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-43.0.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-43.0.ebuild
new file mode 100644
index 000000000000..a29af51cf559
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-43.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ gui-libs/libadwaita:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.15.0
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index 47e411360903..5c8a5c91712c 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1,3 +1,5 @@
DIST xdg-desktop-portal-1.14.6.tar.xz 515076 BLAKE2B fa39b207fa883cd15389d644eb6e6491f8619a4609d3fc9c7e92c039f7247c4b2acbc5031ec25213b61b69d1b14f1f8867b41a20f0d85e4bfd56a9d3d5d715f4 SHA512 2991f435d6808d0838b0ed64f37694dbd9128473edfbc36468e9ee289a962a8c2ec465b87c22a1571801de34bd08ea64b4570dcc3160e03fb6a07270a311e263
+DIST xdg-desktop-portal-1.15.0.tar.xz 521732 BLAKE2B a49ab7a1462771c628a24f9759e239dd3f8233b26c2a5f6e9fc848e00eb36c74a21cd1fd4d43af0c0f46782c46d6a822af86fd7b49fa1f77a1cbd96452a00348 SHA512 98b36841c54bdd5221c0719e9646abb7f117351ff780682591c269d2a57f7b1946deaef38c2caa6474e1048e283a68c55a791e8d2a0be000ca9e563ed98c28ef
EBUILD xdg-desktop-portal-1.14.6.ebuild 1092 BLAKE2B 3ba584de28227ecc1de0b5195e7cbae54443738c336f5bff6780db45036349cba5408fc791546e1c9fbed0139d69e3109bb0bf7435de2ea4a1a6f90c34b3e2c9 SHA512 4d2720260e53a084e9a6047d318a3039d3d8e1d9b2ed251136bf30e622ea686c8f361e2f84260b9b9f13fbf366f2c6906aa3995d5d81f1b3ba5f8c6c9b695171
+EBUILD xdg-desktop-portal-1.15.0.ebuild 1101 BLAKE2B 4d6b6e3812000054d754ca6fca148a16b857b8873a9f33ec996ade8c8a9963100beb0bc57dbcd1523fb87754882d383320d0cca0532482c1d426b8fb7bbf0c05 SHA512 a81895a279473bd0cc57978076dd018854dcb911869c75f6566024f7456c60472b7e248f95efe50545f8c14a5fb458f05afc2bf5fcfb0a033082b759a6c28dcb
MISC metadata.xml 250 BLAKE2B f3e9395137ebb9adf46cd35c1b6156f82c04cfa94f964f6da24fe71eb560cf51b4f70ebfa10daaa4884400ec22782d819ab794dfd29e7a47559f07208397195d SHA512 78c4ff15eed76ba883b457be95dabd41e928a0e64a42b758b5eab4d8a95afca27d5ea6a7cfe0948de578b169153a05f08aadfce1ddd41a88732212a1e76e565f
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.15.0.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.15.0.ebuild
new file mode 100644
index 000000000000..c0589cac6847
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.15.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="geolocation screencast systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.66:2
+ dev-libs/json-glib
+ >=sys-fs/fuse-3.10.0:3[suid]
+ x11-libs/gdk-pixbuf
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-docbook-docs # requires flatpak
+ --disable-libportal # not packaged
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ $(use_with systemd)
+ )
+ econf "${myeconfargs[@]}"
+}