summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/Manifest.gzbin49313 -> 49309 bytes
-rw-r--r--sys-apps/coreutils/Manifest3
-rw-r--r--sys-apps/coreutils/coreutils-9.1-r2.ebuild251
-rw-r--r--sys-apps/coreutils/metadata.xml1
-rw-r--r--sys-apps/pkgcore/Manifest2
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.17-r2.ebuild2
6 files changed, 256 insertions, 3 deletions
diff --git a/sys-apps/Manifest.gz b/sys-apps/Manifest.gz
index 649b5af0bf26..e3d61a9f2ce3 100644
--- a/sys-apps/Manifest.gz
+++ b/sys-apps/Manifest.gz
Binary files differ
diff --git a/sys-apps/coreutils/Manifest b/sys-apps/coreutils/Manifest
index 0a47d25984ed..d4d6665787dd 100644
--- a/sys-apps/coreutils/Manifest
+++ b/sys-apps/coreutils/Manifest
@@ -8,4 +8,5 @@ DIST coreutils-9.1.tar.xz 5712104 BLAKE2B f5654e4935535275615d44a56c071d1c0746af
DIST coreutils-9.1.tar.xz.sig 833 BLAKE2B e9627a066f3c67596feaa8d43d5785076230f440bacea84d8b5736e51a22787c2d5df1f3e2cd8523d01fb7b468933d3c17fce3cb1fbefef322a0e0d820b81842 SHA512 9f0766531afd4faa3e2c337730f61db55605cf06729e9c61f644594883732c2e0b1ddb0005b492be309c53e6f45b8ff875398163a48699d52517ea49e9bdbc91
EBUILD coreutils-8.32-r1.ebuild 5968 BLAKE2B 37f5e49a8d45706ea17779f841523c5f876f29cd9d9d2c88dea33136b249c89853dcea87417f7e4b8c040e9a4b7d1691704301d11116baa567c0cb2b9fa0e17e SHA512 5e2b09e5e4fdb4c34aa0c75b8fbb6aadba98d93063aaf6eff01854e1a1527b9757c73ce35b8da17fe3eb480e04bff88d445305d95ad248bc9461723a9699e33c
EBUILD coreutils-9.1-r1.ebuild 7039 BLAKE2B d5b2ff8ec9f7f6d723386f37767afdcaaefe05bbd8638f2bd5e4161b386f6e41cb10eda8a60147ef412d6a3d393089f87c90494a6dbb397d1156224d80b7b7d2 SHA512 8d916f9b3a7b5c97f75a5a3245cd1e936618487838b72dd069a07a7d32c6ede574a37948790ee4bf833251951eb3d4b68d3bf8dde3605620dd9453cd18ff19b9
-MISC metadata.xml 959 BLAKE2B 7db7eff5a6e1c45c37e20d66e299b44b7a8334b20f970eac2bb7dbf0f8e149784bb19f28c0baa228bdbfbfe0335793080a99aee7f92a9976864ae53a35fc0ac8 SHA512 c69fdd7a27b7980c6e537387a510cfab65d0b252492576ffae3caac930bd2efad29edb604f654c194cc0a485894c8fbd3a5dc63e44359c95fc62fd055066b595
+EBUILD coreutils-9.1-r2.ebuild 7141 BLAKE2B 6ea3c079be282234faa49644235a51be6f417410ac0b023c46bf72a0a165f3faef100e752445059669d53d8cfd3d0fc31566a5a97a4b169f3f337f36a62e8650 SHA512 1e4e4c889adc43f80b3e5749b48e1b1d72e3cf506b29d6cf85ea15858732ea3d2ca68ec820b92d31f171aa81a7989b51789cb7036e6e25d3bf5e3b0b31f5f5f7
+MISC metadata.xml 1043 BLAKE2B db071746d60a62e435bfd6e297641411320b61a5716dc631150e5a3a19bcd49cc6121d2a404b8875d6927ad0114f28d33e2b21edb3bab49559d50fdc26b056f6 SHA512 65149d4bf9b16f7e1800fe8d9e23fa466307ff3f009e06f3736b4f55bce27ba74bc6d1547e0b2f06dcebfcba0f2d21ef3efdd4073ed4e525a2ebdc6e62190119
diff --git a/sys-apps/coreutils/coreutils-9.1-r2.ebuild b/sys-apps/coreutils/coreutils-9.1-r2.ebuild
new file mode 100644
index 000000000000..b3dde9db2968
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-9.1-r2.ebuild
@@ -0,0 +1,251 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Try to keep an eye on Fedora's packaging: https://src.fedoraproject.org/rpms/coreutils
+# The upstream coreutils maintianers also maintain the package in Fedora and may
+# backport fixes which we want to pick up.
+
+PYTHON_COMPAT=( python3_{8..10} )
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/coreutils.asc
+inherit flag-o-matic python-any-r1 toolchain-funcs verify-sig
+
+MY_PATCH="${PN}-9.0_p20220409-patches-01"
+DESCRIPTION="Standard GNU utilities (chmod, cp, dd, ls, sort, tr, head, wc, who,...)"
+HOMEPAGE="https://www.gnu.org/software/coreutils/"
+
+if [[ ${PV} == *_p* ]] ; then
+ # Note: could put this in devspace, but if it's gone, we don't want
+ # it in tree anyway. It's just for testing.
+ MY_SNAPSHOT="$(ver_cut 1-2).193-54bec"
+ SRC_URI="https://www.pixelbeat.org/cu/coreutils-${MY_SNAPSHOT}.tar.xz -> ${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( https://www.pixelbeat.org/cu/coreutils-${MY_SNAPSHOT}.tar.xz.sig -> ${P}.tar.xz.sig )"
+ S="${WORKDIR}"/${PN}-${MY_SNAPSHOT}
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
+
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+fi
+
+SRC_URI+=" !vanilla? ( https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${MY_PATCH}.tar.xz )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="acl caps gmp hostname kill multicall nls +openssl selinux +split-usr static test vanilla xattr"
+RESTRICT="!test? ( test )"
+
+LIB_DEPEND="acl? ( sys-apps/acl[static-libs] )
+ caps? ( sys-libs/libcap )
+ gmp? ( dev-libs/gmp:=[static-libs] )
+ openssl? ( dev-libs/openssl:=[static-libs] )
+ xattr? ( sys-apps/attr[static-libs] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs]} )
+ selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="
+ ${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+"
+BDEPEND="
+ app-arch/xz-utils
+ dev-lang/perl
+ test? (
+ dev-lang/perl
+ dev-perl/Expect
+ dev-util/strace
+ ${PYTHON_DEPS}
+ )
+ verify-sig? ( sec-keys/openpgp-keys-coreutils )
+"
+RDEPEND+="
+ hostname? ( !sys-apps/net-tools[hostname] )
+ kill? (
+ !sys-apps/util-linux[kill]
+ !sys-process/procps[kill]
+ )
+ !app-misc/realpath
+ !<sys-apps/util-linux-2.13
+ !<sys-apps/sandbox-2.10-r4
+ !sys-apps/stat
+ !net-mail/base64
+ !sys-apps/mktemp
+ !<app-forensics/tct-1.18-r1
+ !<net-fs/netatalk-2.0.3-r4"
+
+pkg_setup() {
+ if use test ; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_unpack() {
+ if use verify-sig ; then
+ # Needed for downloaded patch (which is unsigned, which is fine)
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ fi
+
+ default
+}
+
+src_prepare() {
+ local PATCHES=(
+ # Upstream patches
+ "${FILESDIR}"/${P}-fix-rename-simple-backups.patch
+ )
+
+ if ! use vanilla ; then
+ PATCHES+=( "${WORKDIR}"/patch )
+ fi
+
+ default
+
+ # Since we've patched many .c files, the make process will try to
+ # re-build the manpages by running `./bin --help`. When doing a
+ # cross-compile, we can't do that since 'bin' isn't a native bin.
+ #
+ # Also, it's not like we changed the usage on any of these things,
+ # so let's just update the timestamps and skip the help2man step.
+ set -- man/*.x
+ touch ${@/%x/1} || die
+
+ # Avoid perl dep for compiled in dircolors default (bug #348642)
+ if ! has_version dev-lang/perl ; then
+ touch src/dircolors.h || die
+ touch ${@/%x/1} || die
+ fi
+}
+
+src_configure() {
+ local myconf=(
+ --with-packager="Gentoo"
+ --with-packager-version="${PVR} (p${PATCH_VER:-0})"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+ # kill/uptime - procps
+ # groups/su - shadow
+ # hostname - net-tools
+ --enable-install-program="arch,$(usev hostname),$(usev kill)"
+ --enable-no-install-program="groups,$(usev !hostname),$(usev !kill),su,uptime"
+ --enable-largefile
+ $(usex caps '' --disable-libcap)
+ $(use_enable nls)
+ $(use_enable acl)
+ $(use_enable multicall single-binary)
+ $(use_enable xattr)
+ $(use_with gmp libgmp)
+ --with-openssl=$(usex openssl yes no)
+ )
+
+ if use gmp ; then
+ myconf+=( --with-libgmp-prefix="${ESYSROOT}"/usr )
+ fi
+
+ if tc-is-cross-compiler && [[ ${CHOST} == *linux* ]] ; then
+ # bug #311569
+ export fu_cv_sys_stat_statfs2_bsize=yes
+ # bug #416629
+ export gl_cv_func_realpath_works=yes
+ fi
+
+ # bug #409919
+ export gl_cv_func_mknod_works=yes
+
+ if use static ; then
+ append-ldflags -static
+ # bug #321821
+ sed -i '/elf_sys=yes/s:yes:no:' configure || die
+ fi
+
+ if ! use selinux ; then
+ # bug #301782
+ export ac_cv_{header_selinux_{context,flash,selinux}_h,search_setfilecon}=no
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ # Known to fail with FEATURES=usersandbox (bug #439574):
+ # - tests/du/long-from-unreadable.sh} (bug #413621)
+ # - tests/rm/deep-2.sh (bug #413621)
+ # - tests/dd/no-allocate.sh (bug #629660)
+ if has usersandbox ${FEATURES} ; then
+ ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+ "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ fi
+
+ # Non-root tests will fail if the full path isn't
+ # accessible to non-root users
+ chmod -R go-w "${WORKDIR}" || die
+ chmod a+rx "${WORKDIR}" || die
+
+ # coreutils tests like to do `mount` and such with temp dirs,
+ # so make sure:
+ # - /etc/mtab is writable (bug #265725)
+ # - /dev/loop* can be mounted (bug #269758)
+ mkdir -p "${T}"/mount-wrappers || die
+ mkwrap() {
+ local w ww
+ for w in "${@}" ; do
+ ww="${T}/mount-wrappers/${w}"
+ cat <<-EOF > "${ww}"
+ #!${EPREFIX}/bin/sh
+ exec env SANDBOX_WRITE="\${SANDBOX_WRITE}:/etc/mtab:/dev/loop" $(type -P ${w}) "\$@"
+ EOF
+ chmod a+rx "${ww}" || die
+ done
+ }
+ mkwrap mount umount
+
+ addwrite /dev/full
+ #export RUN_EXPENSIVE_TESTS="yes"
+ #export FETISH_GROUPS="portage wheel"
+ env PATH="${T}/mount-wrappers:${PATH}" emake -k check VERBOSE=yes
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ newins src/dircolors.hin DIR_COLORS
+
+ if use split-usr ; then
+ cd "${ED}"/usr/bin || die
+ dodir /bin
+
+ # Move critical binaries into /bin (required by FHS)
+ local fhs="cat chgrp chmod chown cp date dd df echo false ln ls
+ mkdir mknod mv pwd rm rmdir stty sync true uname"
+ mv ${fhs} ../../bin/ || die "Could not move FHS bins!"
+
+ if use hostname ; then
+ mv hostname ../../bin/ || die
+ fi
+
+ if use kill ; then
+ mv kill ../../bin/ || die
+ fi
+
+ # Move critical binaries into /bin (common scripts)
+ # (Why are these required for booting?)
+ local com="basename chroot cut dir dirname du env expr head mkfifo
+ mktemp readlink seq sleep sort tail touch tr tty vdir wc yes"
+ mv ${com} ../../bin/ || die "Could not move common bins!"
+
+ # Create a symlink for uname in /usr/bin/ since autotools require it.
+ # (Other than uname, we need to figure out why we are
+ # creating symlinks for these in /usr/bin instead of leaving
+ # the files there in the first place...)
+ local x
+ for x in ${com} uname ; do
+ dosym ../../bin/${x} /usr/bin/${x}
+ done
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Make sure you run 'hash -r' in your active shells."
+ ewarn "You should also re-source your shell settings for LS_COLORS"
+ ewarn " changes, such as: source /etc/profile"
+}
diff --git a/sys-apps/coreutils/metadata.xml b/sys-apps/coreutils/metadata.xml
index 150e67920b16..ddaba5484b5c 100644
--- a/sys-apps/coreutils/metadata.xml
+++ b/sys-apps/coreutils/metadata.xml
@@ -12,6 +12,7 @@
<flag name="hostname">Build the hostname program</flag>
<flag name="kill">Build the kill program</flag>
<flag name="multicall">Build all tools into a single `coreutils` program akin to busybox to save space</flag>
+ <flag name="openssl">Use openssl libcrypto hash routines for hash functions</flag>
<flag name="split-usr">Enable this if /bin and /usr/bin are separate directories</flag>
</use>
<upstream>
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index 1e498b527e05..f81ce94c8bef 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -3,6 +3,6 @@ AUX pkgcore-0.12.17-fix-prefix.patch 731 BLAKE2B 4487c145393747415717f5bf4845a49
DIST pkgcore-0.12.16.tar.gz 623795 BLAKE2B b591aeaa5d780f0b273d446d1bdbdf33a44d085aa4975d3c5f394820a6f479c15da7850a699c92a56cb280ee028d922551c7226801dea6f4c34620bde3859c31 SHA512 acd7c478b342349e66dfda5ed1284663037b221e39b557215d1441e8a908c845fe26e274bcfd97b1879f5792fc017437cd0fbde1cdffc5ebc595a34fa56d2589
DIST pkgcore-0.12.17.tar.gz 615375 BLAKE2B 9aabdeead2997e53ee3c966c908a231ff5e3b85422844538f47ff7bed03611459224ad7e931a9e94f0e376f221bd5c54f0f77f7883543cbd5b03c4dba6ba591b SHA512 9bad9b6e6177873b9187cff66b6b51c644a59a2d9f01b8ca110bc49006d6f0221c2c3b145d7cf5cec6f3c7526b6751100d56df13350b674a68ab5bbf19f10131
EBUILD pkgcore-0.12.16-r1.ebuild 1449 BLAKE2B a4620deadd0c3e5c59a72b0eea28d15dab8d73449051d59f347a4d37b4a83c69ff8c84cae743b7d8f3344dbac5055c08e6a85282d3680900b9e873131ba9f842 SHA512 cd9676de9f17249a2c0aeb1b266b357c6a700f829a6fe8ba0b9cab5423312ef8874e2f407c29156f894a2c9b64e3a7e98d733f6abff082ec2a199870e629c1e2
-EBUILD pkgcore-0.12.17-r2.ebuild 1249 BLAKE2B 60b698ed2f0d15eb9e51626385417f37453b471937ebb7a5496e5242e74cbf1cd7320171b494a0977ab2c7987567f43ea1257f82533fcf5220729f06ba2b2968 SHA512 dc6f6eeec816c70cea571b1aaad91a82380e2393db4b462d1b7f0e3457e5210df2e646a033e07e9cf37ba38bfc7d29f918fff2cc4cdbfee0257bcdf397e45faf
+EBUILD pkgcore-0.12.17-r2.ebuild 1241 BLAKE2B 67795444045840078c64cad5fb90b58d74ad60e3c991764c5abeae1fc0c9de81366ac8d805d8f83524ea3f11987d07c53746e89568125cd92619233c7259bee5 SHA512 593a11d72ea6db8b6a883533d1e5dedc8e49cec6b90cec7afefa36abe8138ac397860af62af9d94901ed707c08d5493d6ab5017d7c40843a7d182334901f74ab
EBUILD pkgcore-9999.ebuild 1139 BLAKE2B 1030392abec3f120c6e588b7750cdf03b01cce418ed79c85d4b2de5d62e5474d2e0c690294c80f4f0e66d8b38208de409a41e7f0e4bc805424399935670c828c SHA512 cac9cdada2dc91a8e720d40af32dd61d0f4884766d581cf793c39757a43457c0e680abac4b44fe71975cc017e047b8bc79b1bd5586d45f203679814eb427af32
MISC metadata.xml 392 BLAKE2B 98797b18321d3133dceaf79389bd35b26344a342c55c477b178359d731c46fa209adbdcf1d14eb009d57c8c20db8b898651dd45d5bcfc6bb3009ceffa1436650 SHA512 097710cc6c1df7455328a1d3feb223e324162ff20ef03964de4682eec7acf4e2d08fa64d3ac4946783f4c2587455d90ee5aa628f637f3a48386d9c9e6b7362e1
diff --git a/sys-apps/pkgcore/pkgcore-0.12.17-r2.ebuild b/sys-apps/pkgcore/pkgcore-0.12.17-r2.ebuild
index 4c804c52bcce..8443a44534b9 100644
--- a/sys-apps/pkgcore/pkgcore-0.12.17-r2.ebuild
+++ b/sys-apps/pkgcore/pkgcore-0.12.17-r2.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} == *9999 ]] ; then
https://github.com/pkgcore/pkgcore.git"
inherit git-r3
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
fi