summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/Manifest.gzbin49758 -> 49753 bytes
-rw-r--r--sys-apps/flatpak/Manifest2
-rw-r--r--sys-apps/flatpak/flatpak-1.14.5.ebuild120
-rw-r--r--sys-apps/mawk/Manifest2
-rw-r--r--sys-apps/mawk/mawk-1.3.4_p20231102.ebuild2
5 files changed, 124 insertions, 2 deletions
diff --git a/sys-apps/Manifest.gz b/sys-apps/Manifest.gz
index f0c85b090db6..e724fabf4685 100644
--- a/sys-apps/Manifest.gz
+++ b/sys-apps/Manifest.gz
Binary files differ
diff --git a/sys-apps/flatpak/Manifest b/sys-apps/flatpak/Manifest
index 0ecdb0e636bb..58bc3fbce2b3 100644
--- a/sys-apps/flatpak/Manifest
+++ b/sys-apps/flatpak/Manifest
@@ -3,6 +3,8 @@ AUX flatpak-update.service 215 BLAKE2B 803cd26340f06385a753fe29346e464c97cd5bb80
AUX flatpak-update.timer 122 BLAKE2B 1a353a6dee620b5b031451c17e53522b9a4f7f19c2ae85b5ed39615645c4572783bc981002eded8d30a438731bd782a2b405d62656ee3336b7e51cf08a8ef411 SHA512 147296decb8f6d0b07065bb67d96388501aadfbc0de19250d2f3ee0c3585e8c1c702b380d40cd06e4a47ab9b683ad62c29e54c955ac26a735fc0c5b2bc9df2ee
DIST flatpak-1.12.8.tar.xz 1568984 BLAKE2B 6db457eba6b5c03ae4b7037e55f0537821152a80cad8746939fe93008922a9a33ff9f08635613e56a84f2d151826130c497c1e9f7f1e41a5b2dc215882f2eb14 SHA512 5a37d94e12c18a746b222c1ddbd20bddfb22079af1d3a79dc819cdb25f04774c9e4b3a51f9b5ed64f210317e7ec9fb97324ae38ec3430c6a515ba4042805fc57
DIST flatpak-1.14.4.tar.xz 1637484 BLAKE2B cf208c581ad76d46489ba473d290c35907da0d1d473bf2b4792fb56c31e7110cd38f1c6fc4ad04aa3675868d17116ba52a84b028d7b7789c1736cfe26f3cabfe SHA512 3f97096affd4f1de184ded353f1ab403d9f1813b199b9a1595596cc7c5d6b46062aa2ef184255823f50ae95ca60d0542d9b9e520f9a605f9bc51091863bf89b0
+DIST flatpak-1.14.5.tar.xz 1637692 BLAKE2B 180dc094ef3feef1ccefceb562836f55f6e875016588a5984435ea3157498a8746305c16aa2c83044c107fd7f0e8f6c034c326b4ae29ade1c657e82cff353d47 SHA512 552deaaf3e6712a56f33698c20e6b8225c8893fe9a375af897fd99e19c487bf79b19c3e4ce3b00f3caf90020019ff67c628ca6a8f2ae1e6e01db397d2081ab2b
EBUILD flatpak-1.12.8.ebuild 2521 BLAKE2B a40a8e244e916c304d3fcabc6ef5d1ed34b13324186d3612df8d897bd9ad48c146ca2c16c18eb47d399daed883077fb335b2a652c66a73c5273d12f96a7f976f SHA512 8ea51cc5ba42827c09259a2e6d1ca49a19dbde19f0eea7406e7d2ee018a571b58206c3e39903cf96c827fd3b1ee1d6922d2556f1efccd6e1879382d9d08b6a78
EBUILD flatpak-1.14.4-r3.ebuild 2727 BLAKE2B 7a5184c61378185440b0a67bfa58acda18b29d9fe6b4c76d96ff3e95afcae812dd8726cb20c49f13acab164a567c7ea6e83dde9c9062d8b67bb3caf7ef80de2f SHA512 f8dfc00dcb2ac248b792be9a16fc55c075739098c759986a51ff0db0d9c890294c3e69d229ecb9404edb4da0a7957b1d6984e12ccf212495e246babeba9d22b8
+EBUILD flatpak-1.14.5.ebuild 2832 BLAKE2B 5582b785546a5bf44f6934fe1fb86f89d838a10be07911a13749ebd1201cf36cc5f8b088980be18bc5e16aadb98393ea314970a3798f105b5a89e12837356501 SHA512 80e8663ab3a513acbc760a974462c8208fb4353e692d4cafffe2d6a2a9b35a3d7cb073e38e008d74af9486e33bb9a6ef924cce317f80fed92a71244d20d37ae5
MISC metadata.xml 325 BLAKE2B a8ca5c0feaab721a66653a8d5e084d2bba127d75faa0975a4dac7d4d7395801fc69bed88bf13663826188696ee5e25e18afc1b0d5161d27e15f36b9c88487146 SHA512 2736f22e733f2214b80c46b3280f90103e21c3211bea129614bcf372f05803b5d5148d34406e8aa332f7b21090e8aaa698bb1a25d767ccea21d3977f0894f464
diff --git a/sys-apps/flatpak/flatpak-1.14.5.ebuild b/sys-apps/flatpak/flatpak-1.14.5.ebuild
new file mode 100644
index 000000000000..528b56bf57ed
--- /dev/null
+++ b/sys-apps/flatpak/flatpak-1.14.5.ebuild
@@ -0,0 +1,120 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit linux-info python-any-r1 systemd tmpfiles
+
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.xz"
+DESCRIPTION="Linux application sandboxing and distribution framework"
+HOMEPAGE="https://flatpak.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="doc introspection policykit seccomp systemd X"
+RESTRICT="test"
+
+RDEPEND="
+ acct-group/flatpak
+ acct-user/flatpak
+ >=app-arch/libarchive-2.8:=
+ app-arch/zstd:=
+ >=app-crypt/gpgme-1.1.8:=
+ >=dev-libs/appstream-0.12:=
+ >=dev-libs/appstream-glib-0.5.10:=
+ >=dev-libs/glib-2.56:2=
+ >=dev-libs/libxml2-2.4:=
+ dev-libs/json-glib:=
+ dev-libs/libassuan:=
+ >=dev-util/ostree-2020.8:=[gpg(+)]
+ dev-util/ostree[curl]
+ >=gnome-base/dconf-0.26:=
+ gnome-base/gsettings-desktop-schemas
+ net-misc/curl:=
+ >=sys-apps/bubblewrap-0.5.0
+ sys-apps/dbus
+ >=sys-fs/fuse-3.1.1:3=
+ sys-apps/xdg-dbus-proxy
+ X? (
+ x11-apps/xauth
+ x11-libs/libXau:=
+ )
+ x11-libs/gdk-pixbuf:2=
+ policykit? ( >=sys-auth/polkit-0.98:= )
+ seccomp? ( sys-libs/libseccomp:= )
+ systemd? ( sys-apps/systemd:= )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/automake-1.13.4
+ >=sys-devel/gettext-0.18.2
+ virtual/pkgconfig
+ dev-util/gdbus-codegen
+ sys-devel/bison
+ $(python_gen_any_dep 'dev-python/pyparsing[${PYTHON_USEDEP}]')
+ introspection? ( >=dev-libs/gobject-introspection-1.40 )
+ doc? (
+ app-text/xmlto
+ dev-libs/libxslt
+ )
+"
+
+PDEPEND="sys-apps/xdg-desktop-portal"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.14.4-fuse-3-slotted.patch
+)
+
+python_check_deps() {
+ python_has_version "dev-python/pyparsing[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ local CONFIG_CHECK="~USER_NS"
+ linux-info_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # This line fails because locales are in /usr/lib/locale/locale-archive.
+ sed -i 's:^cp -r /usr/lib/locale/C.*:#\0:' tests/make-test-runtime.sh || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-sandboxed-triggers
+ --localstatedir="${EPREFIX}"/var
+ --with-system-bubblewrap
+ --with-system-dbus-proxy
+ --with-tmpfilesdir="/usr/lib/tmpfiles.d"
+ $(use_enable X xauth)
+ $(use_enable doc documentation)
+ $(use_enable doc docbook-docs)
+ $(use_enable introspection)
+ $(use_enable policykit system-helper)
+ $(use_enable seccomp)
+ $(use_with systemd)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0303
+ find "${ED}" -name '*.la' -delete || die
+ # resolve conflict with acct-user/flatpak for #856706
+ rm -rf "${ED}/usr/lib/sysusers.d"
+
+ if use systemd; then
+ systemd_dounit "${FILESDIR}"/flatpak-update.{service,timer}
+ fi
+}
+
+pkg_postinst() {
+ tmpfiles_process flatpak.conf
+}
diff --git a/sys-apps/mawk/Manifest b/sys-apps/mawk/Manifest
index 4540f86b5888..c979e5affe20 100644
--- a/sys-apps/mawk/Manifest
+++ b/sys-apps/mawk/Manifest
@@ -17,6 +17,6 @@ EBUILD mawk-1.3.4_p20230404.ebuild 1295 BLAKE2B 85e2927e940efb9dc57aef06e9e789aa
EBUILD mawk-1.3.4_p20230525.ebuild 1287 BLAKE2B 59efb03946bb4622e88cd97e60a8d0b11b6a8b50fe93060d7f3688d41b1bd3b801876ecc5943fc8bbcec8dcf50823cd3aac1e7d836d97cc63fd12dbd77f65bcc SHA512 bcd28621f48dca59c84a8f91efd2f7420d21f7e9da5b3a3ca5ebcd4b3cf4b787793cc2eb9adeebaae00d0d26b0908aa1e77431af8b73f364c41dabb894782918
EBUILD mawk-1.3.4_p20230730.ebuild 1306 BLAKE2B 76224a3144ee58b83bae51977e799408d654742827c6fca642cb322a43154974aed04cf1b7086b6cf853facfe5ce1bbeac673ab2a9faeeec074b292ebac394e3 SHA512 b6054eb19d2cd6ba4421b368f8567b64d1121c26bb4d35c769f65c9698fb07cedab782fe57ed62ed64f2df74f628e89c2e10088c43265efb5cc1d0011d3cd5b3
EBUILD mawk-1.3.4_p20230808.ebuild 1298 BLAKE2B 18b7463d11b11937c9d2a37c1b227882532feb0f239452a1765e4322e3bdfd70df5a04e5cda1552b4db9fd2ee634b65fab103d5faf4e97fc7574f6c26636f221 SHA512 8fe9ae6257a804ff3efe03a7f30f46d61e50aef86fa8b9703e39146036410481d6067ad6f2f854827a327dbf0bca857555e6031497a6fc975a4fcd161b4d620a
-EBUILD mawk-1.3.4_p20231102.ebuild 1299 BLAKE2B 22796042653dddc320394494469ae094a03e5c8ed4d243cb5c40f918d567282bf93ccd12daa04359316e6fcb4cc77aee215cb077e86dbf0a92e2ef6ddbfd6866 SHA512 4b9675ce052b512ef7c2f85009134d0e52c4cbe09b46d11e7c37f12e26711600d8fd07d45f923af07885d9453808760f624fd343e386697624f6733ac68168b5
+EBUILD mawk-1.3.4_p20231102.ebuild 1298 BLAKE2B 18b7463d11b11937c9d2a37c1b227882532feb0f239452a1765e4322e3bdfd70df5a04e5cda1552b4db9fd2ee634b65fab103d5faf4e97fc7574f6c26636f221 SHA512 8fe9ae6257a804ff3efe03a7f30f46d61e50aef86fa8b9703e39146036410481d6067ad6f2f854827a327dbf0bca857555e6031497a6fc975a4fcd161b4d620a
EBUILD mawk-1.3.4_p20231126.ebuild 1306 BLAKE2B 76224a3144ee58b83bae51977e799408d654742827c6fca642cb322a43154974aed04cf1b7086b6cf853facfe5ce1bbeac673ab2a9faeeec074b292ebac394e3 SHA512 b6054eb19d2cd6ba4421b368f8567b64d1121c26bb4d35c769f65c9698fb07cedab782fe57ed62ed64f2df74f628e89c2e10088c43265efb5cc1d0011d3cd5b3
MISC metadata.xml 422 BLAKE2B 8bd344848b5247eb1858b7cd31d91a796671c321610b826e602d9350e59769a4e6612438d9bf89ee2d6d63c327729d88a9ccb538b162beb816fde2910d0a4d9a SHA512 9adcc3c3b54ee935d3363e874e76f9e9b1efee00faac94184a84d10a6600dad4f11da51d4567acabf63707ca55f9b3d5ac3df107c6de8b38cad1da9891e82086
diff --git a/sys-apps/mawk/mawk-1.3.4_p20231102.ebuild b/sys-apps/mawk/mawk-1.3.4_p20231102.ebuild
index 721ef6651a47..03417dbde52d 100644
--- a/sys-apps/mawk/mawk-1.3.4_p20231102.ebuild
+++ b/sys-apps/mawk/mawk-1.3.4_p20231102.ebuild
@@ -15,7 +15,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-thomasdickey-20230810 )"