summaryrefslogtreecommitdiff
path: root/sys-apps/xdg-desktop-portal
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest2
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index 27a1b172eeb8..4a49af996419 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1,3 +1,5 @@
DIST xdg-desktop-portal-1.2.0.tar.xz 405856 BLAKE2B 8d198c7c18b829f531e34d6526b52776a1acffcb874a2ea93953314710aa18bcb1988ffe190bb7b7f7c0d1c4eb1bc3d39fd2f7da626754730bf64f349ae75d39 SHA512 7c7dff8f1f44b4f564f195a8f9ad2985f6085d16638d18941459cd14d76d8ae7cafaf72f461f2c0c1414a8bace9f3ab4a5416de06edb71df677fd7bdca47f61a
+DIST xdg-desktop-portal-1.4.2.tar.xz 421660 BLAKE2B 5395218fa182947c589ff51cd43b838591e47442b23c4fe0719f0970bff3602e81c4f79ad93890bde97a529ca34a733032e85a1f21f41e9aa230d5c2d40e1136 SHA512 9a19dc8f6899a24f8827ce36447316ce74f293abed469be24adfaa16d18deac0b7c5d77f744eed9b540b54cd23145281dacb6811dc52b34180b21d6dc02efc5a
EBUILD xdg-desktop-portal-1.2.0.ebuild 1045 BLAKE2B 2061bb59d99bb21ed71e5ace6a25f4f5246cb082f4f0d047e30b7ac057848e5e25b4beed6009f56aa60bc4d52b9666826fd791f0716a8777338aaa4c23fce254 SHA512 25119b9438894da1b1bd9500087b6146054eb8d188d3114017bbbaf749d86bb521a9c359980f00007567d8d3a42573f04aa8be5020e046d6bf3435ca1fc615fa
+EBUILD xdg-desktop-portal-1.4.2.ebuild 894 BLAKE2B 369d2ce66f04d952d7112c159d258e558b4e190212d350197397453534cf9f853c90052118429fd5d6322d1cd98df78cb559532d0b825c821414b37549737c7c SHA512 d1b46d5bfe2f976905d452876131d95692722af721b432018ae1b9e0dcbbeb88607797cf2c3fb27bc6b4ad485a2568260e550d9b8352ede0fc3f10751e90129f
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild
new file mode 100644
index 000000000000..2ae2d2c52cae
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc geolocation"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.3
+ )
+"
+DEPEND="
+ dev-libs/glib:2[dbus]
+ sys-fs/fuse:0
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-pipewire
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable doc docbook-docs)
+ $(use_enable geolocation geoclue)
+ )
+ econf "${myeconfargs[@]}"
+}