summaryrefslogtreecommitdiff
path: root/sys-apps/x86info/x86info-1.30_p20190617.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/x86info/x86info-1.30_p20190617.ebuild')
-rw-r--r--sys-apps/x86info/x86info-1.30_p20190617.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/sys-apps/x86info/x86info-1.30_p20190617.ebuild b/sys-apps/x86info/x86info-1.30_p20190617.ebuild
index d8a3b48dfadf..e19af2dd09ea 100644
--- a/sys-apps/x86info/x86info-1.30_p20190617.ebuild
+++ b/sys-apps/x86info/x86info-1.30_p20190617.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{4..8} )
+PYTHON_COMPAT=( python3_{6..8} )
inherit flag-o-matic linux-info python-any-r1 toolchain-funcs
@@ -16,21 +16,19 @@ SRC_URI="https://github.com/kernelslacker/x86info/archive/${COMMIT}.tar.gz -> ${
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
RDEPEND="sys-apps/pciutils:="
-DEPEND="
+DEPEND="${RDEPEND}"
+BDEPEND="
${PYTHON_DEPS}
- ${RDEPEND}"
+ virtual/pkgconfig"
CONFIG_CHECK="~MTRR ~X86_CPUID"
S="${WORKDIR}/${PN}-${COMMIT}"
PATCHES=(
- #"${FILESDIR}"/1.21-pic.patch
- "${FILESDIR}"/${PN}-1.24-pic.patch #270388
- #"${FILESDIR}"/${PN}-1.29-parallel-make-cleanup.patch
- #"${FILESDIR}"/${PN}-1.30-fix-build-system.patch
+ "${FILESDIR}"/${PN}-1.30-pic.patch #270388
+ "${FILESDIR}"/${PN}-1.30-makefile.patch
)
pkg_setup() {
@@ -44,7 +42,7 @@ src_configure() {
-Wdeclaration-after-statement -Wredundant-decls
append-ldflags -Wl,-z,relro,-z,now
- tc-export CC
+ tc-export CC PKG_CONFIG
}
src_compile() {