summaryrefslogtreecommitdiff
path: root/sys-apps/uswid
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/uswid')
-rw-r--r--sys-apps/uswid/Manifest3
-rw-r--r--sys-apps/uswid/metadata.xml22
-rw-r--r--sys-apps/uswid/uswid-0.4.7.ebuild28
3 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/uswid/Manifest b/sys-apps/uswid/Manifest
new file mode 100644
index 000000000000..2f3603e1d21f
--- /dev/null
+++ b/sys-apps/uswid/Manifest
@@ -0,0 +1,3 @@
+DIST uswid-0.4.7.tar.gz 43719 BLAKE2B c99ea760658a5b5f518e6e8aa554515bc0a5246d60c358b6542dda17489fe18f06b2dff7342371944fe36c44562f9e78feb230f6573445c4004568c973b66b87 SHA512 6e8069547efbc06ee5e2792908a292e70612041f303b41d54fc618519f3156a8c88ca9176367c47304dbe80b0199467b913060c8fdbcef1287794cac0a9e695c
+EBUILD uswid-0.4.7.ebuild 664 BLAKE2B 3c09ff6b7df0e84f8479751e0d6c46b4a2887d6e77fae853b01f66d7b046c1be1923f57d5a6ee26ea4d87470e79bae1f8448de9d7f3b947253032bb1398053df SHA512 8888830573aefe7e6922e19552ccb445864bc25205472238d6c2417a0db30e8127035ab4aa57bee321cbfb146fe3d678be94fd2ab3fd8f11c47ebb763e5dd2b7
+MISC metadata.xml 946 BLAKE2B 6aec42fb59ffbbcbff4d2a68861bd93b9625c0230aeb689605f1ee132301558f37ce3f37eaa76650a55436f37b64d10c179b5aa53bc3e259006b6c754b80b008 SHA512 a78e1066ccbcf102725849720da52cec75c434dfca180282126b58dcddac4ed98bfc1d0418495758f7aa0399a5a7c4b72daefe6327488a6fe023ca4bc45964a9
diff --git a/sys-apps/uswid/metadata.xml b/sys-apps/uswid/metadata.xml
new file mode 100644
index 000000000000..36b5e41b4afc
--- /dev/null
+++ b/sys-apps/uswid/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ Using the uSWID tool or Python API allows one to create, convert and merge
+ Software Bill of Materials (SBoM) metadata to and from a number of different
+ formats including SWID, coSWID, CycloneDX, SPDX and goSWID. It can also import
+ SBoM metadata from .ini files, pkgconfig files, PE binaries including EFI ones,
+ and various unspecified firmware files as long as they include the coSWID SBoM
+ header. Last but not least, it can be used to embed coSWID SBoM metadata
+ into PE/EFI binaries.
+ </longdescription>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">uswid</remote-id>
+ <remote-id type="github">hughsie/python-uswid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/uswid/uswid-0.4.7.ebuild b/sys-apps/uswid/uswid-0.4.7.ebuild
new file mode 100644
index 000000000000..b70a42cc1ef2
--- /dev/null
+++ b/sys-apps/uswid/uswid-0.4.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure-Python library and CLI tool for processing SBoM metadata"
+HOMEPAGE="
+ https://github.com/hughsie/python-uswid/
+ https://pypi.org/project/uswid/
+"
+
+# Reminder: relicensed to BSD-2-with-patent between 0.4.7 and 0.5.0
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cbor2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pefile[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest