summaryrefslogtreecommitdiff
path: root/sys-apps/usbmon/usbmon-6.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/usbmon/usbmon-6.1-r1.ebuild')
-rw-r--r--sys-apps/usbmon/usbmon-6.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/usbmon/usbmon-6.1-r1.ebuild b/sys-apps/usbmon/usbmon-6.1-r1.ebuild
new file mode 100644
index 000000000000..a5de8eb9313a
--- /dev/null
+++ b/sys-apps/usbmon/usbmon-6.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Userland for USB monitoring framework"
+HOMEPAGE="https://people.redhat.com/zaitcev/linux/"
+SRC_URI="https://people.redhat.com/zaitcev/linux/${P}.tar.gz"
+
+LICENSE="GPL-2" # GPL-2 only
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:-O2::g' \
+ -e '/_FORTIFY_SOURCE/d' \
+ Makefile || die
+
+ tc-export CC
+}
+
+src_install() {
+ dosbin ${PN}
+ doman ${PN}.8
+ dodoc README
+}