summaryrefslogtreecommitdiff
path: root/sys-apps/systemd/systemd-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd/systemd-9999.ebuild')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index f8eb096a861c..7122881b52d1 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -151,11 +151,10 @@ src_prepare() {
if ! use vanilla; then
PATCHES+=(
- "${FILESDIR}/218-Dont-enable-audit-by-default.patch"
- "${FILESDIR}/228-noclean-tmp.patch"
- "${FILESDIR}/233-systemd-user-pam.patch"
- "${FILESDIR}/236-uucp-group.patch"
- "${FILESDIR}/generator-path.patch"
+ "${FILESDIR}/gentoo-Dont-enable-audit-by-default.patch"
+ "${FILESDIR}/gentoo-systemd-user-pam.patch"
+ "${FILESDIR}/gentoo-uucp-group-r1.patch"
+ "${FILESDIR}/gentoo-generator-path.patch"
)
fi
@@ -204,6 +203,8 @@ multilib_src_configure() {
-Drootprefix="$(usex usrmerge "${EPREFIX}/usr" "${EPREFIX:-/}")"
-Dsysvinit-path=
-Dsysvrcnd-path=
+ # Avoid infinite exec recursion, bug 642724
+ -Dtelinit-path="${EPREFIX}/lib/sysvinit/telinit"
# no deps
-Defi=$(meson_multilib)
-Dima=true
@@ -392,6 +393,7 @@ pkg_postinst() {
enewgroup input
enewgroup kvm 78
+ enewgroup render
enewgroup systemd-journal
newusergroup systemd-bus-proxy
newusergroup systemd-coredump