summaryrefslogtreecommitdiff
path: root/sys-apps/sed/sed-4.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/sed/sed-4.8.ebuild')
-rw-r--r--sys-apps/sed/sed-4.8.ebuild47
1 files changed, 15 insertions, 32 deletions
diff --git a/sys-apps/sed/sed-4.8.ebuild b/sys-apps/sed/sed-4.8.ebuild
index eee25f42b285..3cf0562a1777 100644
--- a/sys-apps/sed/sed-4.8.ebuild
+++ b/sys-apps/sed/sed-4.8.ebuild
@@ -12,40 +12,23 @@ SRC_URI="mirror://gnu/sed/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
-IUSE="acl forced-sandbox nls selinux static"
+IUSE="acl nls selinux static"
-RDEPEND="acl? ( virtual/acl )
- nls? ( virtual/libintl )
- selinux? ( sys-libs/libselinux )"
+RDEPEND="
+ !static? (
+ acl? ( virtual/acl )
+ nls? ( virtual/libintl )
+ selinux? ( sys-libs/libselinux )
+ )
+"
DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_bootstrap_sed() {
- # make sure system-sed works #40786 #650052
- if ! type -p sed > /dev/null || has_version 'sys-apps/sed[forced-sandbox]' ; then
- mkdir -p "${T}/bootstrap"
- printf '#!/bin/sh\nexec busybox sed "$@"\n' > "${T}/bootstrap/sed" || die
- chmod a+rx "${T}/bootstrap/sed"
- PATH="${T}/bootstrap:${PATH}"
- fi
-}
-
-src_prepare() {
- # Don't use sed before bootstrap if we have to recover a broken host sed.
- src_bootstrap_sed
-
- default
-
- if use forced-sandbox ; then
- # Upstream doesn't want to add a configure flag for this.
- # https://lists.gnu.org/archive/html/bug-sed/2018-03/msg00001.html
- sed -i \
- -e '/^bool sandbox = false;/s:false:true:' \
- sed/sed.c || die
- # Make sure the sed took.
- grep -q '^bool sandbox = true;' sed/sed.c || die "forcing sandbox failed"
- fi
-}
+ nls? ( sys-devel/gettext )
+ static? (
+ acl? ( virtual/acl[static-libs(+)] )
+ nls? ( virtual/libintl[static-libs(+)] )
+ selinux? ( sys-libs/libselinux[static-libs(+)] )
+ )
+"
src_configure() {
local myconf=()