summaryrefslogtreecommitdiff
path: root/sys-apps/progress/progress-0.15-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/progress/progress-0.15-r1.ebuild')
-rw-r--r--sys-apps/progress/progress-0.15-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/progress/progress-0.15-r1.ebuild b/sys-apps/progress/progress-0.15-r1.ebuild
new file mode 100644
index 000000000000..7b1766238200
--- /dev/null
+++ b/sys-apps/progress/progress-0.15-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Coreutils Viewer: show progress for cp, rm, dd, and so forth"
+HOMEPAGE="https://github.com/Xfennec/progress"
+SRC_URI="https://github.com/Xfennec/progress/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+ dodoc README.md
+}