summaryrefslogtreecommitdiff
path: root/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild')
-rw-r--r--sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild b/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
index 52df8b15b9ff..f035b7abd422 100644
--- a/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
+++ b/sys-apps/pmount/pmount-0.9.99_alpha-r5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils bash-completion-r1
+inherit eutils user bash-completion-r1
DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
HOMEPAGE="https://launchpad.net/pmount"
@@ -13,9 +13,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86"
IUSE="crypt"
-RDEPEND="
- acct-group/plugdev
- >=sys-apps/util-linux-2.17.2
+RDEPEND=">=sys-apps/util-linux-2.17.2
crypt? ( >=sys-fs/cryptsetup-1.0.6-r2 )"
DEPEND="${RDEPEND}
dev-util/intltool
@@ -23,6 +21,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P/_/-}
+pkg_setup() {
+ enewgroup plugdev
+}
+
src_prepare() {
# Restore default value from pmount <= 0.9.23 wrt #393633
sed -i -e '/^not_physically_logged_allow/s:=.*:= yes:' etc/pmount.conf || die