summaryrefslogtreecommitdiff
path: root/sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild')
-rw-r--r--sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild b/sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild
index e43bb34fb1ae..2fa0665d5f77 100644
--- a/sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild
+++ b/sys-apps/pmount-gui/pmount-gui-0_pre20130806.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-if [ ${PV} = 9999* ]; then
+if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="git://git.tdb.fi/pmount-gui"
inherit git-2
else
@@ -18,17 +18,15 @@ HOMEPAGE="http://git.tdb.fi/?p=pmount-gui.git;a=summary"
LICENSE="BSD-2"
SLOT="0"
-IUSE=""
-COMMON_DEPEND="x11-libs/gtk+:2"
-RDEPEND="${COMMON_DEPEND}
+DEPEND="x11-libs/gtk+:2"
+RDEPEND="${DEPEND}
sys-apps/pmount
virtual/udev"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
+BDEPEND="virtual/pkgconfig"
src_compile() {
- emake CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+ emake CC="$(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
}
src_install() {