summaryrefslogtreecommitdiff
path: root/sys-apps/pacman
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pacman')
-rw-r--r--sys-apps/pacman/Manifest2
-rw-r--r--sys-apps/pacman/pacman-5.0.2-r2.ebuild (renamed from sys-apps/pacman/pacman-5.0.2-r1.ebuild)35
2 files changed, 21 insertions, 16 deletions
diff --git a/sys-apps/pacman/Manifest b/sys-apps/pacman/Manifest
index 66a8cd6c7211..42be8a87c232 100644
--- a/sys-apps/pacman/Manifest
+++ b/sys-apps/pacman/Manifest
@@ -1,4 +1,4 @@
AUX pacman-5.0.2-CVE-2016-5434.patch 3938 BLAKE2B 67ef2e348502753df10f7dbc9235401dcc8fe1e304a718592fafb6e84e7e045635890aeffe5ab808808f02392c6a141add8d97370957cef8fce357c8dd17b90b SHA512 432922e485a2aa1d82d7654c615333bfd8ff74c89fcb3fa5728618d8947175172e043ae231c7bf04387a0770421ccf96bb0d492a061b4da12ea7f212fe07ca30
DIST pacman-5.0.2.tar.gz 3361701 BLAKE2B 499041cb9914991c12c21383aaf36465189ced456ca8b2908d3c036acc3ef9dde0fba1efd823580c12e6d8dbdcaa5e53a7b1329cac347208d1de21702e8f3efa SHA512 94a8cce1a52d2365a993c72f16537f4dbea6100feb8f22e8782cc7d2c1ef8a525a63f3c40bb183294c0faedcc743e3d806d2fc3c50a21ab9b03df2910039d628
-EBUILD pacman-5.0.2-r1.ebuild 2952 BLAKE2B 0cd3a4905b9ca217747786d3e2cb98b01e0371f968799aff33a89885bc07332c9a45f6df41499e515b7c48423ab450ebb7ff4ce909d1561cff2797a6a71cf347 SHA512 451a898cef0974bd1ec2967dfc6d121021cf3176fc3632f4fa4851875d0ea16bb8bebb221cc759f9c9c18b8d9682ca000204da0ad106b83e35ed5c1b6e050695
+EBUILD pacman-5.0.2-r2.ebuild 2892 BLAKE2B cfd40c949162e4cbee77e82a9fb36e9628c5b1ab807c67635422dd65c6b3be1b22809ceef17122d323f644a6c796b06388fdae0bc1e96b8e5cc135fd8902ca84 SHA512 69cbd3d0b71674a47868c9891ca66cac5a03c40d0959f6d84f302bcf14ae12125197e568a71c4aa2f473e97210c4039eecc57f1ee8f41bd6c1063ed7217a8bfb
MISC metadata.xml 675 BLAKE2B 4019b589f7cc08897c958654944004864bebf838e50d32fa18b295ecbf99d137431402dffbda17b9578f3b0c005e46ef0295d8edc73f01f840d5822c478595fc SHA512 52987ad9ce090732316a0fde96b26cfe3a21cdf1f4ba7b4dc661d21568d22a8972e8dbd90afd7a183fca64a13051c2723f2732fafc56413dfeb156fa7d7d0886
diff --git a/sys-apps/pacman/pacman-5.0.2-r1.ebuild b/sys-apps/pacman/pacman-5.0.2-r2.ebuild
index f60a609779c2..37ec0a9e7aaf 100644
--- a/sys-apps/pacman/pacman-5.0.2-r1.ebuild
+++ b/sys-apps/pacman/pacman-5.0.2-r2.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-
+EAPI=7
PYTHON_COMPAT=( python2_7 )
inherit autotools
@@ -19,7 +18,7 @@ else
SRC_URI="https://sources.archlinux.org/other/pacman/${P}.tar.gz"
# Do *not* re-add ~x86!
# https://www.archlinux.org/news/phasing-out-i686-support/
- KEYWORDS="~amd64"
+ KEYWORDS="-* ~amd64"
PATCHES+=( "${FILESDIR}"/${PN}-5.0.2-CVE-2016-5434.patch )
fi
@@ -27,20 +26,26 @@ fi
LICENSE="GPL-2"
SLOT="0/10"
-IUSE="curl debug doc +gpg test"
-COMMON_DEPEND="app-arch/libarchive:=[lzma]
+IUSE="curl debug doc +gpg libressl test"
+COMMON_DEPEND="
+ app-arch/libarchive:=[lzma]
gpg? ( >=app-crypt/gpgme-1.4.0:= )
- dev-libs/openssl:0=
curl? ( net-misc/curl )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
virtual/libiconv
- virtual/libintl"
+ virtual/libintl
+"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
app-text/asciidoc
doc? ( app-doc/doxygen )
- test? ( sys-apps/fakeroot
- sys-apps/fakechroot )"
+ test? (
+ sys-apps/fakeroot
+ sys-apps/fakechroot
+ )
+"
# workaround until tests are fixed/sorted out
RESTRICT="test"
@@ -56,6 +61,7 @@ src_prepare() {
src_configure() {
local myeconfargs=(
+ --disable-static
--localstatedir=/var
--disable-git-version
--with-openssl
@@ -86,11 +92,15 @@ src_install() {
# create /var/chroot/archlinux
# see bug #631754
dodir /var/chroot/archlinux
+ keepdir /var/chroot/archlinux /var/lib/pacman
default
+ find "${D}" -name '*.la' -delete || die
+
# avoid creating stuff inside /var/cache/
# see bug #633742 for more information
rm -r "${D}"/var/cache/pacman
+ rmdir "${D}"/var/cache
}
pkg_postinst() {
@@ -104,9 +114,4 @@ pkg_postinst() {
einfo "Please generate it manually according to the Archlinux documentation:"
einfo "https://wiki.archlinux.org/index.php/Mirror"
einfo ""
- ewarn "Archlinux is dropping support for x86 (i686 called there) entirely"
- ewarn "in Nov 2017. Please keep this in mind when setting up new systems."
- ewarn "For more details see"
- ewarn "https://www.archlinux.org/news/phasing-out-i686-support"
- einfo ""
}