summaryrefslogtreecommitdiff
path: root/sys-apps/memtester/memtester-4.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/memtester/memtester-4.6.0.ebuild')
-rw-r--r--sys-apps/memtester/memtester-4.6.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-apps/memtester/memtester-4.6.0.ebuild b/sys-apps/memtester/memtester-4.6.0.ebuild
index cbdc8875f2a9..e8aa7866a6b9 100644
--- a/sys-apps/memtester/memtester-4.6.0.ebuild
+++ b/sys-apps/memtester/memtester-4.6.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Userspace utility for testing the memory subsystem for faults"
HOMEPAGE="http://pyropus.ca/software/memtester/"
@@ -17,6 +17,8 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
src_configure() {
+ # bug #943794
+ append-cflags -std=gnu17
echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} -DPOSIX -c" > conf-cc || die
echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld || die
}