summaryrefslogtreecommitdiff
path: root/sys-apps/memtest86/files/memtest86-4.3.7-no-clean.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/memtest86/files/memtest86-4.3.7-no-clean.patch')
-rw-r--r--sys-apps/memtest86/files/memtest86-4.3.7-no-clean.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/sys-apps/memtest86/files/memtest86-4.3.7-no-clean.patch b/sys-apps/memtest86/files/memtest86-4.3.7-no-clean.patch
new file mode 100644
index 000000000000..cd8fc66ba094
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-4.3.7-no-clean.patch
@@ -0,0 +1,16 @@
+don't run the clean target when building all as we run into parallel races:
+ - memtest kicks off building of a bunch of .o files
+ - clean runs in parallel which runs `rm` and deletes some of the new .o
+ - memtest goes to link and fails because objects are missing
+
+--- a/Makefile
++++ b/Makefile
+@@ -19,7 +19,7 @@
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o memsize.o error.o smp.o cpuid.o vmem.o random.o
+
+-all: clean memtest.bin memtest
++all: memtest.bin memtest
+
+ # Link it statically once so I know I don't have undefined
+ # symbols and then link it dynamically so I have full