summaryrefslogtreecommitdiff
path: root/sys-apps/mawk/mawk-1.3.4_p20190203-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/mawk/mawk-1.3.4_p20190203-r1.ebuild')
-rw-r--r--sys-apps/mawk/mawk-1.3.4_p20190203-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/mawk/mawk-1.3.4_p20190203-r1.ebuild b/sys-apps/mawk/mawk-1.3.4_p20190203-r1.ebuild
new file mode 100644
index 000000000000..110cbc7c9a0f
--- /dev/null
+++ b/sys-apps/mawk/mawk-1.3.4_p20190203-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${P/_p/-}"
+DESCRIPTION="an (often faster than gawk) awk-interpreter"
+HOMEPAGE="https://invisible-island.net/mawk/mawk.html"
+SRC_URI="ftp://ftp.invisible-island.net/mawk/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+RDEPEND="app-eselect/eselect-awk"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( ACKNOWLEDGMENT CHANGES README )
+
+src_configure() {
+ tc-export BUILD_CC
+ econf
+}
+
+src_install() {
+ default
+
+ exeinto /usr/share/doc/${PF}/examples
+ doexe examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ eselect awk update ifunset
+}
+
+pkg_postrm() {
+ eselect awk update ifunset
+}