summaryrefslogtreecommitdiff
path: root/sys-apps/man-db/man-db-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/man-db/man-db-9999.ebuild')
-rw-r--r--sys-apps/man-db/man-db-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-apps/man-db/man-db-9999.ebuild b/sys-apps/man-db/man-db-9999.ebuild
index f5b961755735..e673f4391432 100644
--- a/sys-apps/man-db/man-db-9999.ebuild
+++ b/sys-apps/man-db/man-db-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-inherit systemd prefix
+inherit systemd prefix tmpfiles
-DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+DESCRIPTION="A man replacement that utilizes berkdb instead of flat files"
HOMEPAGE="http://www.nongnu.org/man-db/"
if [[ "${PV}" = 9999* ]] ; then
inherit autotools git-r3
@@ -192,6 +192,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ tmpfiles_process man-db.conf
+
if [[ $(ver_cut 2 ${REPLACING_VERSIONS}) -lt 7 ]] ; then
einfo "Rebuilding man-db from scratch with new database format!"
su man -s /bin/sh -c 'mandb --quiet --create' 2>/dev/null