summaryrefslogtreecommitdiff
path: root/sys-apps/hwloc/hwloc-2.8.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hwloc/hwloc-2.8.0-r1.ebuild')
-rw-r--r--sys-apps/hwloc/hwloc-2.8.0-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-apps/hwloc/hwloc-2.8.0-r1.ebuild b/sys-apps/hwloc/hwloc-2.8.0-r1.ebuild
index ffa2bf4b6edf..58a9f8a6769c 100644
--- a/sys-apps/hwloc/hwloc-2.8.0-r1.ebuild
+++ b/sys-apps/hwloc/hwloc-2.8.0-r1.ebuild
@@ -3,12 +3,13 @@
EAPI=8
-inherit autotools bash-completion-r1 cuda flag-o-matic systemd toolchain-funcs multilib-minimal
+inherit autotools bash-completion-r1 cuda desktop flag-o-matic systemd toolchain-funcs multilib-minimal
MY_PV="v$(ver_cut 1-2)"
DESCRIPTION="Displays the hardware topology in convenient formats"
HOMEPAGE="https://www.open-mpi.org/projects/hwloc/"
-SRC_URI="https://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+SRC_URI="https://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2
+ https://raw.githubusercontent.com/open-mpi/hwloc/master/contrib/android/assets/lstopo.png"
LICENSE="BSD"
SLOT="0/15"
@@ -107,4 +108,5 @@ multilib_src_install_all() {
bashcomp_alias hwloc-annotate lstopo{,-no-graphics}
find "${ED}" -name '*.la' -delete || die
+ doicon "${DISTDIR}/lstopo.png"
}