summaryrefslogtreecommitdiff
path: root/sys-apps/hw-probe
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hw-probe')
-rw-r--r--sys-apps/hw-probe/Manifest2
-rw-r--r--sys-apps/hw-probe/hw-probe-1.6.5.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/hw-probe/Manifest b/sys-apps/hw-probe/Manifest
index 6fe85d6b02d7..3840aff89d5c 100644
--- a/sys-apps/hw-probe/Manifest
+++ b/sys-apps/hw-probe/Manifest
@@ -1,4 +1,6 @@
AUX README.gentoo 296 BLAKE2B df18c0796912c5cfe6e8f88427ea690512bfd519aa3502528df6f6936571497937a22f8edcd9e9143d915e648f9b341043141cc6d0ae35de55d22d44c0335f6e SHA512 4ae61b89352a4bbe70f4ea1b85eb19e58c2b81475722dda25c289fbe15e7e6e07df51b08471c5d3c5d7a3b12cc09ba599e0d2158dee68c9c66f60908d57b4326
DIST hw-probe-1.6.4.tar.gz 162317 BLAKE2B 5fc5ddf032c6b2504430349089d95be5310a7ac7752a2b6c3c504240dae6572ee773f8360d6449e9122b20de904a7348a2bdc0af660de44f14cf37b16664ef2a SHA512 c812ebdb23f6b8a4df2f2849a29ecc1307c09f758aeb912face6e899510af69f9dee606fb0ff1807a6de1e89a5f7a8b3259b894cc823b9d25efbf26accf60ac4
+DIST hw-probe-1.6.5.tar.gz 163190 BLAKE2B 1d2ceb152d387018f427cd623897f8c4cc8828a6952c54bb9caa673797ac347b64d9daffcddeca16e8274e5ad42c2cff22efe3330209da1eee5476636167f0ad SHA512 68d6709ca4efe82e0e5de3b580c68f76fa31384af0c53645b6609cee14b944a410e58b12ac13f879d8d86220c1088cfaad17dc6edd24cf27700e449add6f6488
EBUILD hw-probe-1.6.4.ebuild 2308 BLAKE2B e1619f4d5de09a5d7d2d2b55623d2db2ea5cd3833ac62c49b65fc8e1bc4af837c5f13bb50570d4a402949203b88035874d87c725eb563552816ac3c2afc065e5 SHA512 03e09dc195acb9f079e8980e6a3cd74cfe4da63a846fd177e27888b047ea974345a6a6d5c50eec59e8ac20899857f143cd268065727c0fe631737f81e0839f07
+EBUILD hw-probe-1.6.5.ebuild 2310 BLAKE2B e0be3c494d1c55e417aa6cda7fb5dce20fbdfde3c7a6a8912dea50d689429d76f1070cc04fbe2d38818db82284d4b14a73ad11bfa3d91f0d07f5d8b999bdc63c SHA512 ff0384687c15d332a47e890f49efae9da2a153eebcd971510b7f47704c10a72b87a1e829cf1faa7a47584259b68aeb1b2742ca38ea46782cbeb7db33cb12061d
MISC metadata.xml 647 BLAKE2B 522741fd8d5f7b64d686ce02dd5ccd7d9ba42df1e50a3e51921fa17c110c6db114ee22d5a903c8bb61a2a5f3884fad5e8b1a929a062af111fd52faf047638ab1 SHA512 ef6e4af1150d72b3cc26ba56267dae006ae8a19a8df2606a9f02df0dc6b091f0bd3dd9caee2171e896dd7b5e582b853f228e899dbd9281dd07b435a1da1f6b7b
diff --git a/sys-apps/hw-probe/hw-probe-1.6.5.ebuild b/sys-apps/hw-probe/hw-probe-1.6.5.ebuild
new file mode 100644
index 000000000000..89965032f4b0
--- /dev/null
+++ b/sys-apps/hw-probe/hw-probe-1.6.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature readme.gentoo-r1
+
+DESCRIPTION="A tool to probe for hardware, check it's operability and find drivers"
+HOMEPAGE="https://github.com/linuxhw/hw-probe/"
+SRC_URI="https://github.com/linuxhw/hw-probe/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ net-misc/curl
+ sys-apps/dmidecode
+ sys-apps/edid-decode
+ sys-apps/hwinfo
+ sys-apps/pciutils
+ sys-apps/smartmontools
+ sys-apps/usbutils
+ virtual/perl-Data-Dumper
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "showing Machine Check Exceptions." app-admin/mcelog
+ optfeature "showing additional I/O statistics." app-admin/sysstat
+ optfeature "showing display data channel (ddc) information." app-misc/ddcutil
+ optfeature "showing smart card (reader) information." dev-libs/opensc
+ optfeature "showing Vulkan GPU hardware information." dev-util/vulkan-tools
+ optfeature "showing information of attached scanners." media-gfx/sane-backends
+ optfeature "showing GPU information provided by MESA." media-libs/mesa
+ optfeature "showing zeroconf statistics." net-dns/avahi
+ optfeature "showing HP printer statistics." net-print/hplip
+ optfeature "showing status about rfkill switches on communication devices." net-wireless/rfkill
+ optfeature "showing additional CPU capabilities." sys-apps/cpuid
+ optfeature "showing hard disk (HDD, SSD, ..) capabilities." sys-apps/hdparm
+ optfeature "showing available I2C sensors." sys-apps/i2c-tools
+ optfeature "showing additional hardware and system information detected by inxi." sys-apps/inxi
+ optfeature "showing information about tested memory for faults." sys-apps/memtester
+ optfeature "showing 'Plug & Play' devices." sys-apps/pnputils
+ optfeature "showing systemd boot process information." sys-apps/systemd
+ optfeature "showing ACPI statistics and tables." sys-power/iasl
+ optfeature "showing information about NUMA." sys-process/numactl
+ optfeature "showing additional GPU information provided by MESA progs." x11-apps/mesa-progs
+ optfeature "showing available Xinput devices." x11-apps/xinput
+}