summaryrefslogtreecommitdiff
path: root/sys-apps/help2man
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/help2man')
-rw-r--r--sys-apps/help2man/Manifest2
-rw-r--r--sys-apps/help2man/help2man-1.48.4.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/help2man/Manifest b/sys-apps/help2man/Manifest
index 6c6acfe3267a..320198d571a0 100644
--- a/sys-apps/help2man/Manifest
+++ b/sys-apps/help2man/Manifest
@@ -1,4 +1,6 @@
AUX help2man-1.46.1-linguas.patch 2352 BLAKE2B c79cf163fc358f08192517527ee59df2ac429fdf8b8bcc4e387ed686d44b3aceebcd517578cbf6348d751ce2fb62f1b7580d6a645a4f912c7fa374eb165b2600 SHA512 5907aed1745b199b0cad44f6e7669c663761b308b2bb1b669be8ba118d990481c37d1da5477df2cfa9cba30ecffe99c3863215779d683f056fe0c41241a0049b
DIST help2man-1.48.3.tar.xz 211504 BLAKE2B 407cc87b1238242c202d37c0c4cd394e0efba95759b86a88026aef7c05d6a097d1946614547ebfab45f7fe0c1ddd057724234629246d32e94862c3d633b78c31 SHA512 e000e7380604c0986b14cb64b852d55eff48595884bddd389e876056dde6ce72b37aa16d92230e6f8f6e128003b819954bae4aa90933a58b51d3665d3c0ba356
+DIST help2man-1.48.4.tar.xz 204592 BLAKE2B 0625af5a0a65daeb459a7445ef6e5a8c9ddbac4ebad5c31134bfbbd5abdc1d05cd5e682d2d1f0d4df36de4fdbbbe22ac7bbbb2c1c5fca4d53ee0c6bfefd63dfb SHA512 fa3f3eabc6010a4a34dc108bfa3b9456b9ea66b343ff2913c32cd6da52ddcf3aa8cb9c05a8b14585f314198aa4ef6f1eebbb185b90a2fb923ab3b2ee7b5e57a9
EBUILD help2man-1.48.3.ebuild 1035 BLAKE2B 2bdcaea0a0b2256abf60dabc5f212b586ff59113f8d3ae541ce21d2f5c7c9a294b18280d741f116ea9dd75d9bdb24480ae6bfd5ac332456174d4ce942ffb997d SHA512 d1bfe5663fe13784f5d08e077f216f3155e44bcddba456413fc495dea90e799703a866f0210c690e4764f8826fb7f2732f8912df095b6e9c1f209432911aae0f
+EBUILD help2man-1.48.4.ebuild 1043 BLAKE2B a409c6688242306b58aa9b395c4800166b31a301bd356cd93505e522169ebb4e1b1b82b61b3f2ed737691956fae33516faf69dd9819b8b07abe4bbc981ab7f23 SHA512 68652e40fd2ab4e8ffd862c9783bc7aa891e76a30419b955891134a7a96f8e132ce08dcb4b1be32937398970dfff57c6a09b401fad7cb6207c16a99a12a2a491
MISC metadata.xml 253 BLAKE2B 295e9d6d93aaa12af413972e1590c67087801cc09c9aa6b59d4606c0f4106d1dacf2baa9858559083b4c6d91beeef218d0729e8593a33788958da6d2897e8ce2 SHA512 54a9069aeb4165d2dff3d473c8001bc51613aac9dff3f7f5e9971a9891a737a31511ffa11cbd523febe581ac1d9de2bdf2f40410f0c4239138f2ccca3ef15555
diff --git a/sys-apps/help2man/help2man-1.48.4.ebuild b/sys-apps/help2man/help2man-1.48.4.ebuild
new file mode 100644
index 000000000000..2f5c10989e9b
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.48.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+ nls? ( dev-perl/Locale-gettext )"
+DEPEND="${RDEPEND}"
+
+DOCS=( debian/changelog NEWS README THANKS ) #385753
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i \
+ -e 's/-shared/-bundle/' \
+ Makefile.in || die
+ fi
+ default
+}
+
+src_configure() {
+ # Disable gettext requirement as the release includes the gmo files #555018
+ local myeconfargs=(
+ ac_cv_path_MSGFMT=$(type -P false)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}