summaryrefslogtreecommitdiff
path: root/sys-apps/help2man/help2man-1.48.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/help2man/help2man-1.48.5.ebuild')
-rw-r--r--sys-apps/help2man/help2man-1.48.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/help2man/help2man-1.48.5.ebuild b/sys-apps/help2man/help2man-1.48.5.ebuild
new file mode 100644
index 000000000000..2f5c10989e9b
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.48.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+ nls? ( dev-perl/Locale-gettext )"
+DEPEND="${RDEPEND}"
+
+DOCS=( debian/changelog NEWS README THANKS ) #385753
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i \
+ -e 's/-shared/-bundle/' \
+ Makefile.in || die
+ fi
+ default
+}
+
+src_configure() {
+ # Disable gettext requirement as the release includes the gmo files #555018
+ local myeconfargs=(
+ ac_cv_path_MSGFMT=$(type -P false)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}