summaryrefslogtreecommitdiff
path: root/sys-apps/guix
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/guix')
-rw-r--r--sys-apps/guix/Manifest1
-rw-r--r--sys-apps/guix/guix-1.0.1-r1.ebuild166
2 files changed, 167 insertions, 0 deletions
diff --git a/sys-apps/guix/Manifest b/sys-apps/guix/Manifest
index fdc163c03ad8..a9eae9b3a3f5 100644
--- a/sys-apps/guix/Manifest
+++ b/sys-apps/guix/Manifest
@@ -6,5 +6,6 @@ DIST guix-bootstrap-armhf-linux-20150101-guile-2.0.11.tar.xz.bootstrap 2717576 B
DIST guix-bootstrap-i686-linux-20131110-guile-2.0.9.tar.xz.bootstrap 2656076 BLAKE2B a2c0c82ac3ba4ff5265a506bbe644dc6a61a38cec243e34e8d3bde2d543a4d7221aa921f57f057eb5379aea4e9fd462f0bee7df7e61e4e6381c93401948a9b11 SHA512 f2b257e5b10dcd7421273d8d04782a2bd733781094dd963bf5bd8294604dbd158ea25cbc383a227edce84de968a962ec834226ebdd137a2e1857e2191bfada8c
DIST guix-bootstrap-mips64el-linux-20131110-guile-2.0.9.tar.xz.bootstrap 2734180 BLAKE2B 8ac6d9cfb59b1e2214c112fa7bfe865966cd06cb0214f360dc337a54e16cb59e4e3aa6da0662a52e6bceedfbb2a9ebb0eb62fe08491e5761912e2ee17b7ecd48 SHA512 8c4be098a31f63d56e7d35c174ce4095ba8317662c365d44c005980b38ba499461926754a4659e699ab271bb841c9da514f1a36b812d881c212a5f12177d73c0
DIST guix-bootstrap-x86_64-linux-20131110-guile-2.0.9.tar.xz.bootstrap 2885996 BLAKE2B c16595fcb821468d5d293201046642dd4f0b149bb5e64f7b784f29f513ce26243b9747a8eefee3128e813a9b4b27a6a60a1693706b3fcb8cbb238fb4ad6e56c1 SHA512 96efc583f42f6c7647bc026e2d2a96d603e7bea12ca02f6bcc65e819b9966082ac4c9f7e42f64536ff42a988e4766e695d87a82c73dd97d80745975a05badb23
+EBUILD guix-1.0.1-r1.ebuild 4654 BLAKE2B a5359b2c9641e6dca4a781e3e666ffd33bae15b944f94878135b4e730bdda4b881e046460099520d74ec8173fca7437d1d11bd1a96d75dda1f0eb49d8908c08b SHA512 e3b07b2b2d41a2031fd4fc2fa802e590e8b1924c1cedb31da1c914f2f0b7d24be9d2cd7226d6d7ec8f70a6d9275c9f00e736a1dcb569f023e165a27c78c7d7da
EBUILD guix-1.0.1.ebuild 4561 BLAKE2B e83b2007f66bef0612f6aea68f894645c0856a41312857ceef3d3084e4f684d69d87a37a9f7fa1cf6c49f7b585dfc73fab1240c2a588ba9b60c73021aedbeaa1 SHA512 60c31ddb829937de5995e643be99739267345a5ea4aed91953ca593e3d4ac71bc6674cd41bf9019da2fdd0524af91f6f1b69e7a76a45a1af4bff7a75dc2e5d66
MISC metadata.xml 251 BLAKE2B 9785c4729d0751280d104965bab25a268219a7fee217dcd8c01a5642a13f8abc471a3dff54ae0d34d3cf3dc8267fb483d93bd3b16aa3617e8fa8e9abd1703dfe SHA512 cc2bd3977894946ee4ea5b739cc3998bcd6017b9e7a52aa501409d0988954339a9a22fe751d0a5e967ddac9225d9b23f20b4fb1e2c62ee91d1d23c383d9776dd
diff --git a/sys-apps/guix/guix-1.0.1-r1.ebuild b/sys-apps/guix/guix-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..0ab61861e615
--- /dev/null
+++ b/sys-apps/guix/guix-1.0.1-r1.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info readme.gentoo-r1 systemd user
+
+DESCRIPTION="GNU package manager (nix sibling)"
+HOMEPAGE="https://www.gnu.org/software/guix/"
+
+# taken from gnu/local.mk and gnu/packages/bootstrap.scm
+BOOT_GUILE=(
+ "aarch64-linux 20170217 guile-2.0.14.tar.xz"
+ "armhf-linux 20150101 guile-2.0.11.tar.xz"
+ "i686-linux 20131110 guile-2.0.9.tar.xz"
+ "mips64el-linux 20131110 guile-2.0.9.tar.xz"
+ "x86_64-linux 20131110 guile-2.0.9.tar.xz"
+)
+
+binary_src_uris() {
+ local system_date_guilep uri
+ for system_date_guilep in "${BOOT_GUILE[@]}"; do
+ # $1 $2 $3
+ # "armhf-linux 20150101 guile-2.0.11.tar.xz"
+ set -- ${system_date_guilep}
+ uri="mirror://gnu-alpha/${PN}/bootstrap/$1/$2/$3"
+ # ${uri} -> guix-bootstrap-armhf-linux-20150101-guile-2.0.11.tar.xz.bootstrap
+ echo "${uri} -> guix-bootstrap-$1-$2-$3.bootstrap"
+ done
+}
+
+# copy bootstrap binaries from DISTDIR to ${S}
+copy_boot_guile_binaries() {
+ local system_date_guilep
+ for system_date_guilep in "${BOOT_GUILE[@]}"; do
+ # $1 $2 $3
+ # "armhf-linux 20150101 guile-2.0.11.tar.xz"
+ set -- ${system_date_guilep}
+ cp "${DISTDIR}"/guix-bootstrap-$1-$2-$3.bootstrap gnu/packages/bootstrap/$1/$3 || die
+ done
+}
+
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ $(binary_src_uris)"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # complains about size of config.log and refuses to start tests
+
+RDEPEND="
+ dev-libs/libgcrypt:0=
+ >=dev-scheme/guile-2.2:=[regex,networking,threads]
+ dev-scheme/bytestructures
+ dev-scheme/guile-gcrypt
+ >=dev-scheme/guile-git-0.2.0
+ dev-scheme/guile-json
+ dev-scheme/guile-sqlite3
+ net-libs/gnutls[guile]
+ sys-libs/zlib
+ app-arch/bzip2
+ dev-db/sqlite
+"
+
+DEPEND="${RDEPEND}
+"
+
+PATCHES=("${FILESDIR}"/${PN}-0.16.0-default-daemon.patch)
+
+QA_PREBUILT="usr/share/guile/site/*/gnu/packages/bootstrap/*"
+
+DISABLE_AUTOFORMATTING=yes
+DOC_CONTENTS="Quick start user guide on Gentoo:
+
+[as root] allow binary substitution to be downloaded (optional)
+ # guix archive --authorize < /usr/share/guix/ci.guix.info.pub
+[as root] enable guix-daemon service:
+ [systemd] # systemctl enable guix-daemon
+ [openrc] # rc-update add guix-daemon
+[as a user] ln -sf /var/guix/profiles/per-user/\$USER/guix-profile \$HOME/.guix-profile
+[as a user] install guix packages:
+ \$ guix package -i hello
+[as a user] configure environment:
+ Somewhere in .bash_profile you might want to set
+ export GUIX_LOCPATH=\$HOME/.guix-profile/lib/locale
+
+Next steps:
+ guix package manager user manual: https://www.gnu.org/software/guix/manual/guix.html
+"
+
+pkg_pretend() {
+ # USER_NS is used to run builders in a default setting in linux
+ # and for 'guix environment --container'.
+ local CONFIG_CHECK="~USER_NS"
+ check_extra_config
+}
+
+pkg_setup() {
+ enewgroup guixbuild
+ for i in {1..10}; do
+ # we list 'guixbuild' twice to
+ # both assign a primary group for user
+ # and add a user to /etc/group
+ # 'kvm' is used to make 'guix system vm <system.scm>'
+ # work by default: bug #699642
+ enewuser guixbuilder${i} -1 -1 /var/empty guixbuild,guixbuild,kvm
+ done
+}
+
+src_prepare() {
+ copy_boot_guile_binaries
+
+ default
+ # build system is very eager to run automake itself: bug #625166
+ eautoreconf
+
+ # guile is trying to avoid recompilation by checking if file
+ # /usr/lib64/guile/2.2/site-ccache/guix/modules.go
+ # is newer than
+ # guix/modules.scm
+ # In case it is instead of using 'guix/modules.scm' guile
+ # loads system one (from potentially older version of guix).
+ # To work it around we bump last modification timestamp of
+ # '*.scm' files.
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+
+ # Gentoo stores systemd unit files in lib, never in lib64: bug #689772
+ sed -i nix/local.mk \
+ -e 's|systemdservicedir = $(libdir)/systemd/system|systemdservicedir = '"$(systemd_get_systemunitdir)"'|' || die
+}
+
+src_configure() {
+ # to be compatible with guix from /gnu/store
+ econf \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ # guile occasionally fails with 'bad address'
+ emake -j1
+}
+
+src_install() {
+ # TODO: emacs highlighter
+ default
+
+ readme.gentoo_create_doc
+
+ keepdir /etc/guix
+ # TODO: will need a tweak for prefix
+ keepdir /gnu/store
+ fowners root:guixbuild /gnu/store
+ fperms 1775 /gnu/store
+
+ keepdir /var/guix/profiles/per-user
+ fperms 1777 /var/guix/profiles/per-user
+
+ newinitd "${FILESDIR}"/guix-daemon.initd guix-daemon
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}