summaryrefslogtreecommitdiff
path: root/sys-apps/gsmartcontrol
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gsmartcontrol')
-rw-r--r--sys-apps/gsmartcontrol/Manifest2
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-1.1.4.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/gsmartcontrol/Manifest b/sys-apps/gsmartcontrol/Manifest
index 0482f4c6c0e3..a8c815af6db3 100644
--- a/sys-apps/gsmartcontrol/Manifest
+++ b/sys-apps/gsmartcontrol/Manifest
@@ -1,3 +1,5 @@
DIST gsmartcontrol-1.1.3.tar.bz2 677998 BLAKE2B f444dd29602f6934b440650e57d5d981a3b9823a905ce3c178109b230e6536edd4f38ed0762872b38186774127a164feb7363bb45cbd80e9c0b34398c1a06092 SHA512 7a8bb79875a53d742923fc8ff8336d7fbbdaf2e1b1f64296840557997125d4dcfea9a93a5e8a834003d592083a180ee85ca0e29d3aecf0eb475a3d4fed460456
+DIST gsmartcontrol-1.1.4.tar.bz2 691155 BLAKE2B 484452b85e848ca9d0539f9fb9e63fc60f837d5e5de1d85d6ef6340fba194ea52cb2026682b263b1391a59eee4ee846dad3863dc1f0bd00296015ddcf86dda9a SHA512 a59147f7adb76fa1cfc55198d175b38f7840c0ec07563bc020757d7609891c8f67953b87a867235821f90c52bc3c8e40a8d8a57a1429e4b75a3afb3a2ada42f1
EBUILD gsmartcontrol-1.1.3.ebuild 1009 BLAKE2B 68fbd4e99795031f6d1124cd756f30f271746a7546ffdafb0d9c0d765292e3415e163edec83d6d692fd21ce29aab2d3fcc2db0e38817939d561458a28e21037b SHA512 a05864d911a09af9a435d3c132e5aae57eb8a458fcb818a18d4d4040af55467b620aa35a8b8a202acc3dd32fe9722a0c1afc474b223dae5a8f934a9daa83f97c
+EBUILD gsmartcontrol-1.1.4.ebuild 811 BLAKE2B 262fe0dee900cbb0436717bd8bd5804c34766e292c4d0003df07721e667b2ccfe1b98974530c3829598cdd4618db78b0d5b3012b423fe7b0b5ea6526b3ca605f SHA512 3f698126ff2a7b3739210b48723b94b325d92c8556283dc6155e5466851d87cd1a8c2214a788874beae5d9fc62085aabd735e6878625e95f41a6e005640f19f2
MISC metadata.xml 341 BLAKE2B 0186090acb3718e9c11fd0acea1cbfcbb7222abda56ede52e5c40fd30b61572504a7905b86962c446a87b4ec0b5d7787d5e2beb8255130d97b40f8255f328843 SHA512 df6c99e8f920b1588d2ddea188ff4a9b4553e75a0c5d1a98d43c2ba1b46ef24a7a63a06865db71ab61cdf761b885a1017ca622966cd4ba5462c32a3822464a67
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-1.1.4.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.4.ebuild
new file mode 100644
index 000000000000..2dc9c0c0ebad
--- /dev/null
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic xdg
+
+DESCRIPTION="Hard disk drive health inspection tool"
+HOMEPAGE="https://gsmartcontrol.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-cpp/gtkmm:3.0
+ dev-libs/libpcre:3
+ sys-apps/smartmontools"
+RDEPEND="${DEPEND}
+ x11-apps/xmessage"
+BDEPEND="virtual/pkgconfig
+ test? ( dev-util/gtk-builder-convert )"
+
+DOCS=( TODO ) # See 'dist_doc_DATA' value in Makefile.am
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ econf $(use test tests)
+}
+
+src_install() {
+ default
+
+ rm "${ED}"/usr/share/doc/${PF}/LICENSE_* || die
+}