summaryrefslogtreecommitdiff
path: root/sys-apps/grep/files/ppc-musl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/grep/files/ppc-musl.patch')
-rw-r--r--sys-apps/grep/files/ppc-musl.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/sys-apps/grep/files/ppc-musl.patch b/sys-apps/grep/files/ppc-musl.patch
new file mode 100644
index 000000000000..d7d8255a444a
--- /dev/null
+++ b/sys-apps/grep/files/ppc-musl.patch
@@ -0,0 +1,18 @@
+Needed to fix build on ppc + musl. Doesn't seem to yet be in upstream gnulib.
+
+https://www.openwall.com/lists/musl/2017/11/05/2
+https://github.com/void-linux/void-packages/blob/master/srcpkgs/grep/patches/ppc-musl.patch
+--- a/lib/sigsegv.c
++++ b/lib/sigsegv.c
+@@ -221,8 +221,10 @@ int libsigsegv_version = LIBSIGSEGV_VERSION;
+ /* both should be equivalent */
+ # if 0
+ # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
+-# else
++# elif defined(__GLIBC__)
+ # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
++# else
++# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
+ # endif
+ # endif
+