summaryrefslogtreecommitdiff
path: root/sys-apps/gcp/gcp-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gcp/gcp-0.2.1.ebuild')
-rw-r--r--sys-apps/gcp/gcp-0.2.1.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/sys-apps/gcp/gcp-0.2.1.ebuild b/sys-apps/gcp/gcp-0.2.1.ebuild
index 3425601feba6..a3cfc30ce969 100644
--- a/sys-apps/gcp/gcp-0.2.1.ebuild
+++ b/sys-apps/gcp/gcp-0.2.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
-inherit distutils-r1
+inherit distutils-r1 virtualx
DESCRIPTION="File copying utility with progress and I/O indicator"
HOMEPAGE="https://code.lm7.fr/mcy/gcp"
@@ -15,10 +15,22 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/progressbar[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]"
+distutils_enable_tests unittest
+
PATCHES=( "${FILESDIR}"/${PN}-0.2.1-gentoo-fhs.patch )
+
+src_test() {
+ export $(dbus-launch)
+ virtx distutils-r1_src_test
+ kill -9 "${DBUS_SESSION_BUS_PID}"
+}
+
+python_test() {
+ local -x PATH="${S}:${PATH}"
+ "${EPYTHON}" test/test_gcp.py || die "Tests fail with ${EPYTHON}"
+}