summaryrefslogtreecommitdiff
path: root/sys-apps/gawk
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/Manifest3
-rw-r--r--sys-apps/gawk/gawk-5.1.1-r1.ebuild102
-rw-r--r--sys-apps/gawk/gawk-5.1.1.ebuild96
3 files changed, 201 insertions, 0 deletions
diff --git a/sys-apps/gawk/Manifest b/sys-apps/gawk/Manifest
index 2257cd626d5e..37429e6be61e 100644
--- a/sys-apps/gawk/Manifest
+++ b/sys-apps/gawk/Manifest
@@ -1,3 +1,6 @@
DIST gawk-5.1.0.tar.xz 3154564 BLAKE2B a969b03f45e1d830d2b3760d75530de97eb521a35ac448cf441d7fd2d1a8c1059bd9240cb9571f58ef6ec122864ced3d274a07453c3138177deda895ac3433d9 SHA512 971e6a7617eb051d587984f64be2ff830e49eb60721c3401e8944401e3c3a7cd3334f0334b6e28bfc9283aaff15d83b0933f1fd77b0f8c7059068fa3f94c3cb4
+DIST gawk-5.1.1.tar.xz 3250860 BLAKE2B 35eec6f4c9bf52496ac16e4b0e1b98947ae0dd46d0ab1df9ec13ede24374a4917214e492182a16e25fc515fa62a765340914feac16a006d980ba1328634a5291 SHA512 794538fff03fdb9a8527a6898b26383d01988e8f8456f8d48131676387669a8bb3e706fa1a17f6b6316ddba0ebe653c24ad5dd769f357de509d6ec25f3ff1a43
EBUILD gawk-5.1.0.ebuild 2272 BLAKE2B eefcb6bd789cc7681873db57a83d1a9e1b00f4f2bc2b2d7df67252537f87f99436e0922abfb61ceba1ea21e80090d605df726f23ba17a002501f802c9ba2f06b SHA512 9ed71f1ef8e5178df8332d328fb037c39b8f7017a8bd3020867c1210ba26ca6d7272de26b26b5892b6965c21019403754c34864dc0aa7c0ff124e212abc876cf
+EBUILD gawk-5.1.1-r1.ebuild 2431 BLAKE2B f2a48d0d138bd18da5698c3cc821ce6e98148bb543b6fa391385b2a6d6f9ab27f4dabc1c3d21096c123c143a70a977f77d3e5ffce394e9da0b243b9aecb440f5 SHA512 b92e9db130955698c2274b32c7eef9fcb21c24c9c1e90f5b8646ac64156f31b8b363aa2e9a8fecbd7ac5839416243e7cd136cb5dd5a8fb7d70598cc88019fb20
+EBUILD gawk-5.1.1.ebuild 2280 BLAKE2B 32860987ff3cbb1ba0c6bc7c35432a229f1eff36aff50b2ad42a7d39f33c785f30a9ab53a96315ce6aa63f090b062e23d0a6132362004658f07d70655342fa3a SHA512 f847f241617b0368c06d1af0453160b96a22f2afb29d8ae9df1119416935f110a1e9a0bc0c331bd14ccfe85807e8dbcef53d15e2a2a510fee239a02909cd3d6d
MISC metadata.xml 348 BLAKE2B dd212d42a4218147703b0dd20699b3040aa7fa6e214d26b7919e7e547a71d4ba22f827aa952952ad97314f90444fb27dbd79da73988f33084c457e1a358b5d1c SHA512 8a6da25157316d3caf69f2a2f68c93d98ba76e89304237b2df04032db39849349c1911e69037da4d8789d8c284792de1071e7eda66e62f2be5523806c6f13223
diff --git a/sys-apps/gawk/gawk-5.1.1-r1.ebuild b/sys-apps/gawk/gawk-5.1.1-r1.ebuild
new file mode 100644
index 000000000000..c8b984dd637c
--- /dev/null
+++ b/sys-apps/gawk/gawk-5.1.1-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GNU awk pattern-matching language"
+HOMEPAGE="https://www.gnu.org/software/gawk/gawk.html"
+SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="mpfr nls readline"
+
+RDEPEND="
+ mpfr? (
+ dev-libs/gmp:=
+ dev-libs/mpfr:=
+ )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-apps/texinfo-6.7
+ >=sys-devel/bison-3.5.4
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ default
+
+ # Use symlinks rather than hardlinks, and disable version links
+ sed -i \
+ -e '/^LN =/s:=.*:= $(LN_S):' \
+ -e '/install-exec-hook:/s|$|\nfoo:|' \
+ Makefile.in doc/Makefile.in || die
+
+ # bug #413327
+ sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in || die
+
+ # Fix typo in configure
+ # https://lists.gnu.org/archive/html/bug-gawk/2021-10/msg00022.html
+ sed -i -e 's/AR_FLAGS = /AR_FLAGS=/' configure || die
+
+ # Fix standards conflict on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i \
+ -e '/\<_XOPEN_SOURCE\>/s/1$/600/' \
+ -e '/\<_XOPEN_SOURCE_EXTENDED\>/s/1//' \
+ extension/inplace.c || die
+ fi
+}
+
+src_configure() {
+ # Avoid automagic dependency on libsigsegv
+ export ac_cv_libsigsegv=no
+
+ local myeconfargs=(
+ --libexec='$(libdir)/misc'
+ $(use_with mpfr)
+ $(use_enable nls)
+ $(use_with readline)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ # Automatic dodocs barfs
+ rm -rf README_d || die
+
+ default
+
+ # Install headers
+ insinto /usr/include/awk
+ doins *.h
+ rm "${ED}"/usr/include/awk/config.h || die
+}
+
+pkg_postinst() {
+ # Symlink creation here as the links do not belong to gawk, but to any awk
+ if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
+ eselect awk update ifunset
+ else
+ local l
+ for l in "${EROOT}"/usr/share/man/man1/gawk.1* "${EROOT}"/usr/bin/gawk ; do
+ if [[ -e ${l} ]] && ! [[ -e ${l/gawk/awk} ]] ; then
+ ln -s "${l##*/}" "${l/gawk/awk}" || die
+ fi
+ done
+
+ if ! [[ -e ${EROOT}/bin/awk ]] ; then
+ ln -s "../usr/bin/gawk" "${EROOT}/bin/awk" || die
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
+ eselect awk update ifunset
+ fi
+}
diff --git a/sys-apps/gawk/gawk-5.1.1.ebuild b/sys-apps/gawk/gawk-5.1.1.ebuild
new file mode 100644
index 000000000000..0d846599ecd1
--- /dev/null
+++ b/sys-apps/gawk/gawk-5.1.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GNU awk pattern-matching language"
+HOMEPAGE="https://www.gnu.org/software/gawk/gawk.html"
+SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="mpfr nls readline"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ mpfr? ( dev-libs/mpfr:0= )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-apps/texinfo-6.7
+ >=sys-devel/bison-3.5.4
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ default
+
+ # Use symlinks rather than hardlinks, and disable version links
+ sed -i \
+ -e '/^LN =/s:=.*:= $(LN_S):' \
+ -e '/install-exec-hook:/s|$|\nfoo:|' \
+ Makefile.in doc/Makefile.in || die
+
+ # bug #413327
+ sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in || die
+
+ # Fix standards conflict on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i \
+ -e '/\<_XOPEN_SOURCE\>/s/1$/600/' \
+ -e '/\<_XOPEN_SOURCE_EXTENDED\>/s/1//' \
+ extension/inplace.c || die
+ fi
+}
+
+src_configure() {
+ # Avoid automagic dependency on libsigsegv
+ export ac_cv_libsigsegv=no
+
+ local myeconfargs=(
+ --libexec='$(libdir)/misc'
+ $(use_with mpfr)
+ $(use_enable nls)
+ $(use_with readline)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ # Automatic dodocs barfs
+ rm -rf README_d || die
+
+ default
+
+ # Install headers
+ insinto /usr/include/awk
+ doins *.h
+ rm "${ED}"/usr/include/awk/config.h || die
+}
+
+pkg_postinst() {
+ # Symlink creation here as the links do not belong to gawk, but to any awk
+ if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
+ eselect awk update ifunset
+ else
+ local l
+ for l in "${EROOT}"/usr/share/man/man1/gawk.1* "${EROOT}"/usr/bin/gawk ; do
+ if [[ -e ${l} ]] && ! [[ -e ${l/gawk/awk} ]] ; then
+ ln -s "${l##*/}" "${l/gawk/awk}" || die
+ fi
+ done
+
+ if ! [[ -e ${EROOT}/bin/awk ]] ; then
+ ln -s "../usr/bin/gawk" "${EROOT}/bin/awk" || die
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
+ eselect awk update ifunset
+ fi
+}