summaryrefslogtreecommitdiff
path: root/sys-apps/findutils
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/Manifest1
-rw-r--r--sys-apps/findutils/findutils-4.9.0-r2.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/sys-apps/findutils/Manifest b/sys-apps/findutils/Manifest
index 5a27f5cf6d4c..bae210a03ded 100644
--- a/sys-apps/findutils/Manifest
+++ b/sys-apps/findutils/Manifest
@@ -1,4 +1,5 @@
DIST findutils-4.9.0.tar.xz 2046252 BLAKE2B 3ada8903fc552ad2e580a7b631a4b9d941935b3f4231029564c6f2b7b10ba6f2244e2de57f6d79268c5e0481a193f64edbbae637e7a51ae6f495e3eefabf52c9 SHA512 ba4844f4403de0148ad14b46a3dbefd5a721f6257c864bf41a6789b11705408524751c627420b15a52af95564d8e5b52f0978474f640a62ab86a41d20cf14be9
DIST findutils-4.9.0.tar.xz.sig 488 BLAKE2B 7aab47ccb1351f08be03e781332b79d6778ff0d5d7959adf75fa8eab11325ee9971c89972338edfb58daac7f702891a1a5dd8379a703ccfa601e6b99db588197 SHA512 b8e0b5471242912a20b9e468fa27b7f27339af5f7be8918173105262dee0152183bf4cf516844d348b206a694e028490d5d3b190f3aed8c698ba5444941f8dfc
EBUILD findutils-4.9.0-r1.ebuild 2117 BLAKE2B d70aba6309ccdbe7035f40844de967b4708590201e0bb51f212ca5cba2d3c446117c8dbf1eed5444aba82f12ec223072474de92534206fdfebd34ad79c4d9f74 SHA512 59c4da8b925afbc04a2264944bd48d7d60a1961457f764aaba965ed51d7c008c706422cb36d775bd281a2ae87c888d764fbca7bf5e57f39c709bf39b28e1dfaa
+EBUILD findutils-4.9.0-r2.ebuild 2407 BLAKE2B c6375d243fcc96d628745bf8b1d2af6b9b84a19719e29fca58769641f81bb2ae1802ac0bc06b63d36f82256599ffe52f3983c2c0eb07c028b24ae1d96a840523 SHA512 8b0ce846f7eed7035a597dafa36247b3308a032f076af01dcefe90b1cf152a1b514f72b36d582a602324e9b01d106e315b36ecdb13077b2e3ea25257416cad53
MISC metadata.xml 333 BLAKE2B 321643b5c847879de4e8c0a4abebd5534e91fc7e58313ec3258520fc1f1266f98cc1892b57589cd1427ad4a0cea39b3c03ce12741b04f75290346fddc6c245fe SHA512 b36dfd42e3af70bc1ef3c7629297a390dced3edb1dc3d7d10d7672ff532da743453d9382cb15d3102885150c2440bd85019865d61c4e4342004db2dcf993f0a2
diff --git a/sys-apps/findutils/findutils-4.9.0-r2.ebuild b/sys-apps/findutils/findutils-4.9.0-r2.ebuild
new file mode 100644
index 000000000000..86f171f6797f
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.9.0-r2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/findutils.asc
+inherit flag-o-matic python-any-r1 verify-sig
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="https://www.gnu.org/software/findutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls selinux static test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ dev-util/dejagnu
+ )
+ verify-sig? ( sec-keys/openpgp-keys-findutils )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't build or install locate because it conflicts with mlocate,
+ # which is a secure version of locate. See bug 18729
+ sed \
+ -e '/^SUBDIRS/s@locate@@' \
+ -e '/^built_programs/s@ frcode locate updatedb@@' \
+ -i Makefile.in || die
+
+ default
+}
+
+src_configure() {
+ if use static; then
+ append-flags -pthread
+ append-ldflags -static
+ fi
+
+ append-lfs-flags
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00050.html
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00051.html
+ append-cppflags '-D__nonnull\(X\)='
+ fi
+
+ local myeconfargs=(
+ --with-packager="Gentoo"
+ --with-packager-version="${PVR}"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+ $(use_enable nls)
+ $(use_with selinux)
+ --libexecdir='$(libdir)'/find
+ # rename to gfind, gxargs for better BSD compatibility
+ --program-prefix=g
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+ default
+}
+
+src_compile() {
+ # We don't build locate, but the docs want a file in there.
+ emake -C locate dblocation.texi
+ default
+}
+
+src_install() {
+ default
+
+ # symlink to the standard names
+ dosym gfind /usr/bin/find
+ dosym gxargs /usr/bin/xargs
+ dosym gfind.1 /usr/share/man/man1/find.1
+ dosym gxargs.1 /usr/share/man/man1/xargs.1
+}