summaryrefslogtreecommitdiff
path: root/sys-apps/ethq/ethq-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ethq/ethq-9999.ebuild')
-rw-r--r--sys-apps/ethq/ethq-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-apps/ethq/ethq-9999.ebuild b/sys-apps/ethq/ethq-9999.ebuild
index 11b6f2389400..da954c3b0cc6 100644
--- a/sys-apps/ethq/ethq-9999.ebuild
+++ b/sys-apps/ethq/ethq-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
EGIT_REPO_URI="https://github.com/isc-projects/${PN}.git"
-inherit git-r3 toolchain-funcs
+inherit git-r3 flag-o-matic toolchain-funcs
DESCRIPTION="Ethernet NIC Queue stats viewer"
HOMEPAGE="https://github.com/isc-projects/ethq"
@@ -35,6 +35,13 @@ src_prepare() {
fi
}
+src_configure() {
+ # https://github.com/isc-projects/ethq/issues/30 (bug #879893)
+ filter-lto
+
+ default
+}
+
src_compile() {
# override for ncurses[tinfo]
emake CXX="$(tc-getCXX)" LIBS_CURSES="$($(tc-getPKG_CONFIG) --libs ncurses)"