summaryrefslogtreecommitdiff
path: root/sys-apps/ethq/ethq-0.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ethq/ethq-0.6.1.ebuild')
-rw-r--r--sys-apps/ethq/ethq-0.6.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-apps/ethq/ethq-0.6.1.ebuild b/sys-apps/ethq/ethq-0.6.1.ebuild
index 172f1ef054f7..9165d5a82da5 100644
--- a/sys-apps/ethq/ethq-0.6.1.ebuild
+++ b/sys-apps/ethq/ethq-0.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
MY_PV=${PV//./_}
MY_P=${PN}-${MY_PV}
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Ethernet NIC Queue stats viewer"
HOMEPAGE="https://github.com/isc-projects/ethq"
@@ -37,6 +37,13 @@ src_prepare() {
fi
}
+src_configure() {
+ # https://github.com/isc-projects/ethq/issues/30 (bug #879893)
+ filter-lto
+
+ default
+}
+
src_compile() {
# override for ncurses[tinfo]
emake CXX="$(tc-getCXX)" LIBS_CURSES="$($(tc-getPKG_CONFIG) --libs ncurses)"